Announcement

Collapse
No announcement yet.

Return after inserting...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ctmservice
    started a topic Return after inserting...

    Return after inserting...

    In my application, the "Return after inserting" in -> application -> navigation when it is set to "yes" still generates a new record and does not go in edit mode.
    To mention that I use blocks in the form (mainly for the lay-out) and the orientation (under settings) is "single record"

    With a new generated form in the same application it works. So there should be a difference, but what is it?

    How to solve this. Can I do this with code....? Very important for me..

    Regards, Bert Steinebach

  • aducom
    replied
    I'm the first to admit that there are issues. We are developing with at 10 dev licence and we have reported loads of issues over the years. Not all of them are addressed and unfortunately status of some is quite in the dark. I don't want to repeat all the things I have written about support etc. as they can be found easily on this forum. I am critical. But I must be hostest too. We have learned to bypass issues by work-arounds etc. It does mean that we loose precious time, but on the other hand we have gained a lot of time too. As long as the benefits are bigger then the disadvantages (...)

    Leave a comment:


  • MilanB
    replied
    Look at this:
    - I buy SC at 5.jan.2017
    - I started to create app at 8.jan.2017
    ​- it happens to me 3 times
    - last time to day
    - it a danger to touch app in project
    - every day when I work with SC I found some bugs or malfunctions
    - environment is unstabile
    - no coding standards in generated code
    - third party libs are old
    - generated code is a mesh
    - I try to report bugs but there is no way to do that
    - support gay is giving only early beginners advise

    This is really annoying.

    I try to catch attention of creators and make them to wake up and do something with SC.
    The last hope is SC9.
    The SC8 is not deserve to be bought. It is like a bad beta version.
    And that is true.


    Anyway I like your posts and you are doing a really good job.
    But I can say the same about NetMake.


    example of the dependency injection in final code:
    $modulo - is a name of another object stored in property
    every object has only public properties and methods
    in the all code not used constructor method
    PHP Code:
    class grid_xxxxxx_apl {
       function 
    prep_modulos($modulo)
       {
          
    $this->$modulo->Ini $this->Ini;
          
    $this->$modulo->Db $this->Db;
          
    $this->$modulo->Erro $this->Erro;
          
    $this->$modulo->Lookup $this->Lookup;
          
    $this->$modulo->arr_buttons $this->arr_buttons;
       } 

    Leave a comment:


  • aducom
    replied
    I haven't had this issue for ages. So there's a combination the leads to this. Hard issues to find if it is not reproducable. We are all devs and know issues like these. It happens ... sometimes. But please don't yell on the forum, it won't help you and annoys guys like me who are trying to help on a volunteer basis.

    Leave a comment:


  • MilanB
    replied
    The same happend to me a several time. It is more than 2 years after this post and the bug is still there. I try to solve with support team (waste of time) and answer was something like that
    "This is a not reproducible bug so it is OK and nobody will work on it".
    IT IS NOT OK THIS IS A CORE BUG.

    Leave a comment:


  • ctmservice
    replied
    Albert, this remark is not ment to upset you. You helped me getting working the solution. Thank you for that. But as a technician I donot know the reason. Thats why.
    But perhaps somebody of the compagny reacts
    Regards, Bert

    Leave a comment:


  • aducom
    replied
    Bert, I am not an employee from Scriptcase, just a reseller. If I was in charge a lot of things would change. But I have to do with the product as it is and can only give advise how to do things best. I don't like beautiful solutions, I like working solutions. (is the slogan of aducom software ;-)

    Leave a comment:


  • ctmservice
    replied
    Albert,

    I followed your advise.....its working fine now.....but you will agree it's not the most beauty way

    Regards Bert Steinebach

    Leave a comment:


  • aducom
    replied
    Hi Bert, sometimes things get messed up. You can put a lot of hours into it to find the reason, best way generally is to start the form again and copy-paste event code if it exists. Don't delete the failing module and use the same name because not all is deleted somehow. Just create a new app under a different name.

    Leave a comment:

Working...
X