No announcement yet.

Strange issue with Master/Detail Forms: Buttons Vanish!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange issue with Master/Detail Forms: Buttons Vanish!

    I have a master and detail form which shows fine locally:

    However when I upload the deployed project files to the server, the add, update, and delete buttons vanish from the detail form:

    Also on the server, if a master record doesn't have any detail record(s) it just says Records not found rather than showing a form to insert a record:

    I have tried using an editable grid for the detail form, but the edit/pencil icon doesn't show up.

    Now Im going crazy so I hop a fresh pair of eyes can help. I must be missing something?



  • #2
    did you move your database also to the other server? i think if you don't have records on this form-attached table then you will not have those buttons
    also i noticed once that buttons were not displayed in IE due to themes or buttons issue perhaps, try with different browser?


    • #3
      Thanks for the reply, yes I uploaded the database and also tried it in both IE and Chrome. Same result.


      • #4
        strange then i guess!
        did you deploy to the server along with your full libraries?
        i would suggest you do once an express edit and choose your template and theme once more / apply to all applications you have before uploading fully to the production server
        pair of new eyes would be more difficult


        • #5
          Thank you for replying. I did deploy all libraries. However I will give your suggestions a try.



          • #6
            Still had no luck with this! Anyone else have any other ideas?

            Am I missing something, did I not configure something while making the master/details forms?

            Here is what I did:
            I made 2 forms (single record)

            The mysql db table for agent-contacts has a foreign key to link it with agents.

            Then I selected Master/Detail on the agents form in SC and followed the steps and linked the key fields.

            I have selected all the options in the Form Property section:

            Form Property
            Check - Enable insert button on target application
            Check - Enable update button on target application
            Check - Enable delete button on target application
            Check - Enable navigation button on target application
            Check - Keep Where Clause on target application
            Last edited by gamer99; 06-14-2014, 07:58 AM.


            • #7

              I had the same issue, check if you have rights to add, edit and delete on your forms/grids.
              You can configure it in your Menu->Security->Groups/Applications.

              I hope it helps.


              • #8
                Thanks for the reply and help.