No announcement yet.

[SOLVED] Code generation error (license related)

  • Filter
  • Time
  • Show
Clear All
new posts

  • RHS
    No other errors ...

    But, i have restarted now the whole server and the errors are gone. Strange things ...

    Leave a comment:

  • aducom
    Is this related to some kind of soap error message I get sometimes lately when starting scriptcase?

    Leave a comment:

  • RHS
    I have today the same error ...:

    exec() function.exec: Unable to fork [./zendid allid] | Script: /var/www/.../scriptcase7/devel/class/generator/nmGerador.class.php linha: 958

    Cannot identify the Server.
    Try again, if the problem persists, contact NetMake (
    Which server is actually meant?

    Leave a comment:

  • bartho
    Re: Code generation error (license related)

    Hello radiantekno,

    Are you still experiencing any trouble?

    Please contact our support regarding this issue. Our chat is active on workdays from 8:00am to 6:00pm, and our ticket system is always available.

    Bernhard Bernsmann

    Leave a comment:

  • radiantekno
    started a topic [SOLVED] Code generation error (license related)

    [SOLVED] Code generation error (license related)

    Dear Scriptcase,

    I am a registered user of scriptcase v6 enterprise, with a valid enterprise license.

    Recently I have inserted my scriptcase license and it seems to be okay.
    Then I tried build and generate an application, at first the generation process shows an error message "ScriptCase : Cannot identify the Server. Try again, if the problem persists, contact NetMake".

    I try to look at the error.log, and it says that "./zendid: not found", when I try to execute the zendid binary manually, it also displaying the same error message (zendid: not found). I understand that this might be a 32-bit binary, so I try to execute the zendid.linux64 (I am installing scriptcase on a Linux-64 bit server), and It show the following message:

    *** If multiple IDs are shown, you can use either of them for licensing.

    I thought my problems are solved, so I try to rename the original zendid binary into other name, and copy the zendid.linux64 binary to zendid. When I try to generate again, the generation process display another error message:

    Version not permitted for this server.
    Contact NetMake (

    I have tried to install the 32-bit compatibility in my linux installation (so the original zendid binary can run), and restore the original zendid binary, but it doesn't do any good either (same version not permitted error message).
    For your information, I am installing the 64bit version of Scriptcase for Linux on Ubuntu 12.04 LTS 64-bit.

    What do I have to do to resolve this problem?
    Please Help ASAP.


    Ronnie I. Kurniawan