No announcement yet.

Can't choose Database Name in PROD environment

  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Hable con un operador :

    Ramon Ranieri:Lo Scriptcase 8 no funciona com el PHP 5.5.9

    Ramon Ranieri:solamente con la versiĆ³n 5.4 para el Scriptcase 8 o a 5.6 para el Scriptcase 8.1

    Tendre que pasarme a la 8.1 o hacer un downgrade en el servidor de produccion con lo que eso implica.


    • #47
      I understand that this is a very old thread but I did have the same problem and developed a reasonably good workaround.

      The issue is, as has been previously posted, that php 5.5, which is part of many distributions, has deprecated certain php commands which are generated by older versions of Scriptcase. It is impractical to change php code after scriptcase generation since that defeats the purpose of Scriptcase which is to automatically generate working php code.

      Likewise, it is impractical to expect users to downgrade their servers or php version since other applications in their distribution rely on the higher php versions.

      Install a program called phpbrew. Once installed, you can then install multiple versions of PHP side by side on your server and choose which version you want to use at the command line but this is only part of the solution since scriptcase applications are run under apache2.

      The rest of the solution involves configuring apache2 to run with the version of php that you need (5.4) under, in my case, /etc/apache2/mods-available and activating it in /etc/apache2/mods-enabled. Restart the webserver and you will be good to go.

      I believe that after you have configured the database in scriptcase production environment, you can return apache2 to the latest php version in /etc/apache2/mods-available, restart apache2 and your scriptcase application will still run. At least mine did.

      I would be happy to provide additional details if anyone is still chasing this issue.
      Last edited by claudesimon; 01-22-2017, 05:05 PM.