Announcement

Collapse
No announcement yet.

Can't choose Database Name in PROD environment

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Igors
    started a topic Can't choose Database Name in PROD environment

    Can't choose Database Name in PROD environment

    Hello All.

    Recently have started to use SC.

    Problem:
    After deployment can't choose Database Name in Production Environment when creating or editing DB connection.
    Simply there is blank dropdown list.

    Test Connection shows Connection Success.

    Tried:
    Change DBMS Type (MySQL (Transaction), MySQL, MySQL PDO) no success...

    Sequence:
    Applications shows: "Error while accessing the database: No database selected".


    Maybe someone can help.
    Thanks.

  • claudesimon
    replied
    I understand that this is a very old thread but I did have the same problem and developed a reasonably good workaround.

    The issue is, as has been previously posted, that php 5.5, which is part of many distributions, has deprecated certain php commands which are generated by older versions of Scriptcase. It is impractical to change php code after scriptcase generation since that defeats the purpose of Scriptcase which is to automatically generate working php code.

    Likewise, it is impractical to expect users to downgrade their servers or php version since other applications in their distribution rely on the higher php versions.

    Install a program called phpbrew. Once installed, you can then install multiple versions of PHP side by side on your server and choose which version you want to use at the command line but this is only part of the solution since scriptcase applications are run under apache2.

    The rest of the solution involves configuring apache2 to run with the version of php that you need (5.4) under, in my case, /etc/apache2/mods-available and activating it in /etc/apache2/mods-enabled. Restart the webserver and you will be good to go.

    I believe that after you have configured the database in scriptcase production environment, you can return apache2 to the latest php version in /etc/apache2/mods-available, restart apache2 and your scriptcase application will still run. At least mine did.

    I would be happy to provide additional details if anyone is still chasing this issue.
    Last edited by claudesimon; 01-22-2017, 05:05 PM.

    Leave a comment:


  • gaston
    replied
    Hable con un operador :

    Ramon Ranieri:Lo Scriptcase 8 no funciona com el PHP 5.5.9


    Ramon Ranieri:solamente con la versión 5.4 para el Scriptcase 8 o a 5.6 para el Scriptcase 8.1

    Tendre que pasarme a la 8.1 o hacer un downgrade en el servidor de produccion con lo que eso implica.

    Leave a comment:


  • gaston
    replied
    Hola alguna solucion ?????????????????????????????

    Leave a comment:


  • jealfonso
    replied
    The postings have been placed long time ago and there is no final solution yet. I am having this problem now. Please help

    Leave a comment:


  • abduh
    replied
    Follow these 'backdoor' step :

    1. Find the file "nmPageAdminSysAllConectionsCreateWizard.class.php " in this folder :
    ..your_app_folder..\_lib\prod\lib\php\devel\class\ page
    2. Find and replace syntax : 'mysql_connect()' with 'mysqli_connect()'
    3. Save the file
    4. Back to your production environment page, Edit your database connection
    5. Fill in database field manually
    6. Save and logout

    Leave a comment:


  • james123
    replied
    Hi,
    I have the same problem, I solve it by install parallel php as fastCGI, you can find the answer in :http://www.jabommi.de/wiki/downgrade...-php-versions/
    My system is Ubuntu 14, php-5.5.9, and now I can swatch my website to php-5.4.33 and no need to downgrade, it work

    Leave a comment:


  • gbonnet
    replied
    Ok good news
    I did solved it while watching php logs :
    I used a password with accent (xxxéyyy) for the database access : the wizzard can connect to the database but fails to retrieve installed bases !!!!
    seems to be a bug somewhere in the mysql access.
    Anyhow : avoid using special characters to access your mysql database !!!
    By the way : the used version of php (I saw some concerns about 5.5) has nothing to do with the bug.. till now, my wamp 2.5 is ok for deployed project

    Hope it helps
    Last edited by gbonnet; 11-24-2014, 05:09 PM.

    Leave a comment:


  • gbonnet
    replied
    Same problem since almost the beginning og this thread : I cannot choose database when configuring production environment....I am using wamp server 2.5

    Leave a comment:


  • nnara530
    replied
    I want to know whether scriptcase has resolved this issue or not? Right now I am using 7.1

    My Production Environments are

    Server version: 5.5.37-35.0-log
    PHP version 5.4

    My production env has only the following options to switch back PHP 5.2 or PHP 5.3

    Big disappointment. Need quick resolution for this bug from SC ASAP.

    It is still not listing the database I tried all three (MySQL Transaction, MySQL, MySQL PDO)

    Regards
    Narayanan

    Leave a comment:


  • nnara530
    replied
    I want to know whether scriptcase has resolved this issue or not? Right now I am using 7.1

    My Production Environments are

    Server version: 5.5.37-35.0-log
    PHP version 5.4

    My production env has only the following options to switch back

    PHP 5.2 or PHP 5.3

    It is still not listing the database I tried all three (MySQL Transaction, MySQL, MySQL PDO)

    Big disappointment. Need quick resolution for this bug from SC ASAP.

    Regards
    Narayanan

    Leave a comment:


  • nnara530
    replied
    Hi Welectronic,

    Thank you for your reply. The issue is my production hosting provider have only php versions of PHP 5.2, PHP 5.3 or 5.4.

    I can do the above in my local environment but not the production environment. Are you saying that if I install the above and do a build and deploy package and then it will work in any production environment?

    Or my production environment also need to be similar to the above?

    I am surprised why ScriptCase is not acting on this issue as this will have a larger customer impact. Big disappointment from SC. I keep upgrading SC; now I need to seriously think twice before upgrading next time .

    Regards
    Narayanan

    Leave a comment:


  • welectronic
    replied
    i had the same issue, after i read many forums an treads, decided to downgrade the wamp version to 2.4 from the main webpage of wamp developer (http://sourceforge.net/projects/wamp...pserver%202.4/) my SC version is 7.01.0021 and i'm working now without problems

    php.jpg

    tuve el mismo problema, después de leer muchos foros y muchos hilos, decidi bajar la versión de mi servidor desde la pagina de wamp, mi version de SC es 7.01.0021 y ahora estoy trabajando sin problema alguno

    Leave a comment:


  • nnara530
    replied
    Hi,

    Now I am not getting this error but however it is not listing any databases

    Can some one help me here?

    Regards
    Narayanan

    Leave a comment:


  • Giu
    replied
    Originally posted by nnara530 View Post
    Hi

    I too have this problem . I am getting the following error

    Connection Error

    Unable to connect: Connection attempt failed: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    My Production Environments are

    Server version: 5.5.37-35.0-log
    PHP version 5.4

    My production env has only the following options to switch back

    PHP 5.2 or PHP 5.3

    I am not sure which environment to switch back

    I am in very bad state now

    Regards
    Narayanan
    Did you installed mysql-server package? Your error isn't The same of this thread. Your error shows it can't connect to mysql server, and has more to do with with connection Params .

    Leave a comment:

Working...
X