Announcement

Collapse
No announcement yet.

Pdf export don't work after deployment on other server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I tried the same but unfortunately no result....... same 'not found' message.

    Comment


    • #17
      Martin,

      Can you please share your Production environment settings and the log file that would have got generated after running PDF? Let me see if I can help you; after spending couple of days I think I have a fair idea how to debug this. May be I can make a video and post it in YouTube

      Comment


      • #18
        Hi Nnara,

        Thanks for your offer!
        Big difference between my development system is that it runs HTTP on OSX and acceptance and production HTTPS on Ubuntu. On acceptance and production I also have some Apache mods like mod_security, which could be the cause. I'm going to build my development system soon on an new VPS, running Ubuntu and test without https and these mods and see if this could be the cause.
        I think it must be somewhere here. Also I cannot export to xls, rtf or any other format which should be possible.
        I'll keep you updated about the results.

        Thanks,
        Martin

        Comment


        • #19
          Got it working on my test system. Issue was a http password configured in .htaccess. After removing the password it worked. Did the same on production system, but there still it is not working (difference is php version, migrating prd to a new VPS soon)

          Comment


          • #20
            All the best

            Comment


            • #21
              I had the same problem and solved it downloading the latest version wkhtmltopdf file and copy into _lib/prod/third/wkhtmltopdf/amd-386 folder (linux)
              Now since last version of sc the page size seems to be changed. What to do ?

              Comment

              Working...
              X