Announcement

Collapse
No announcement yet.

Fatal error: Redefinition of parameter $uid

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fatal error: Redefinition of parameter $uid

    I converted from v8 to v9 and see this error when i wanted to run the application under development environment:

    "Fatal error: Redefinition of parameter $uid in C:\Program Files\NetMake\v9\wwwroot\scriptcase\app\project_x1 0\form_commerce_order\index.php on line 3324"


    Line: 3324: function ajax_form_commerce_order_lkpedt_refresh_billing_pr ofile_id($uid, $uid, $nmgp_refresh_fields, $script_case_init)
    {
    global $inicial_form_commerce_order;
    //register_shutdown_function("form_commerce_order_pa ck_ajax_response");
    $inicial_form_commerce_order->contr_form_commerce_order->NM_ajax_flag = true;
    $inicial_form_commerce_order->contr_form_commerce_order->NM_ajax_opcao = 'lkpedt_refresh_billing_profile_id';
    $inicial_form_commerce_order->contr_form_commerce_order->NM_ajax_info['param'] = array(
    'uid' => NM_utf8_urldecode($uid),
    'uid' => NM_utf8_urldecode($uid),
    'nmgp_refresh_fields' => NM_utf8_urldecode($nmgp_refresh_fields),
    'script_case_init' => NM_utf8_urldecode($script_case_init),
    'buffer_output' => true,
    );

    I deleted the project and do the conversion again. I also just update to the latest version this morning. They didn't work.

    It works when i run the application under v8.

  • #2
    Sad nobody from Scriptcase bothers to respond since August 2017...even if "Demund" found a solution I thought I share this. Just today, I run into this same problem 2019-04-14. The problem comes out of nowhere, I simply added a temporary field to a form and wam bam!!! Fatal error: Redefinicion of parameter $xxx... which happens in some internal SC code so you would expect they bother with helping licensed hoders and make a better name for themselves but they do not!!!... $$$$. My rant is over... I deleted the new temp field from the form and still got the same error. I then inspected all the fields for conflicts on "reserved" names or variable names used by "Scriptcase" bam!!!,,, one of my field is called "lenguage"... and I needed to put that field under it's own block to avoid the form being mal-formed with fields "scattered" all over the screen with "huge spacing gaps" between fields and labels and that is another problems Scritpcase will NOT fix.... if ACCESS has drag and drop to build screens why don't Scriptcase do the same? and let me place labels and fiels where I need them to be?.... ok RANT#2 is now over!!!.. THE SOLUTION TO THIS OBSCURE AND "FATAL" ERROR was: I changed the NAME OF THE BLOCK I was using from "language" to "language" to another name like... "language_something_else". problem fixed... thanks SC...

    Comment


    • #3
      Hi javierx1, I am exactly in the same situation, it has been the creation of a virtual field and the fatal error has appeared. The solution has been to rename the block. Thank you for your post. My SC version is 9.4.15

      Comment

      Working...
      X