Announcement

Collapse
No announcement yet.

BUGS in version 9.4.003

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BUGS in version 9.4.003

    We have multiple problems with the new version 9.4.003

    1.- The code that compiled correctly with the latest version 9.3 now gives several errors and there are applications that do not compile correctly.
    2.- Internal libraries do not work when they are run from a blank application.
    3.- The modifications of the css code that started with # have stopped working.

    It is assumed that the new versions include new functionality but that the previous functionality should continue to work!

    We have not seen at any time any notice that warned that the code should be modified !!!!!

    We CANNOT modify ALL the code of the applications that we have already developed.

    PLEASE Scriptcase solve all these problems as soon as possible since we are locked.

  • #2
    Please, send this report to bugs @ scriptcase.net. They don't follow this forum on a regular base.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Thanks Albert for answering.
      We have sent the problems and the answer has been:

      1.- Regarding the modifications of the css code with the ids that start with #, they have told us that it was a bug but they don't know when it will be solved.

      2.- Regarding the internal Libraries that until version 9.3 it was only necessary to activate them, now it is necessary to use the sc_include macro. It is incredible that they do something like this, which involves modifying all the applications that are already working.

      3.- The third problem of application compilation errors that had no problem with version 9.3, the answer has been that we verify the max_execution_time parameter of our development server. No doubt this factor has NOTHING to do with problems.

      I write all this in case someone is in the same situation that we can have the information updated today 08/29/2019.

      Regards

      Comment


      • #4
        Hi,
        I have raised similar bugs to SC team and they are also trying to solve the bugs I believe. We have been exchanging emails since the release of 9.4 update.

        I have errors like source code generation fail where the app remains outdated and then logs me out of the development environment. I solved it like this:
        1 back up
        2 download and fresh install SC
        3 set "Use session in database" to NO in options>settings
        4 restore from back up
        5 continue as is

        I think some bugs exist when Use session in database is set to YES.

        Comment


        • #5
          Hi mistergrey,
          Thanks for answering. In our case, we have always set the option "Use sessions in the database" to No.

          This afternoon we have been talking with support and they have told us that:
          1.- Regarding the # bug in the id of the css, they don't know when it will be solved.
          2.- Regarding having, now, to use the sc_include macro for INTERNAL libraries, they say is not a bug and must be used. It is surprising that in the previous versions it was not necessary.
          3.- Regarding the rest of the problems, we have been told to try a manual installation that solves many problems !!!!!!

          Now we are doing the manual installation, but I guess we will stay the same.

          Regards

          Comment


          • #6
            We'll see. #1, that's a bad response. We had to wait over half a year to get some serious issues fixed, we almost had to quit SC. Option 2: Very odd. Almost everybody is using just the checkbox thing as that should generate the include as it did always. #3, I don't believe that, or it should be that your install has been corrupted. Personally i haven't upgraded yet, and I think we'll wait a while.
            Albert Drent
            aducom software netherlands
            scriptcase partner, reseller, support and (turn-key) development
            www.scriptcase.eu / www.scriptcase.nl

            Comment


            • #7
              To whom it May concern,

              In the end, the manual installation of version 9.4.003 did NOT solve anything at all.

              Scriptcase passed us a link with a zip of version 9.3.013 and we decided to try our luck and perform the manual installation of the zip (we previously made a copy of the entire scriptcase folder) to try to return to the previous version according to the indications of the following link https://scriptcase-support.kayako.co...manual-windows.

              After doing so we recompile the code and:

              1.- We no longer had any compilation error saying "Fatal error: Maximum execution time of 300 seconds exceeded"
              2.- The id of the css with # worked again
              3.- The internal libraries too.

              Who is in the same situation as us, we recommend that you ask Scriptcase for the zip with the previous version and install it with the manual procedure.

              It is really a shame that Scriptcase makes such disastrous and unproven updates in different environments and with different functionalities.

              Now all users will wait a long time before updating anything, even if they put nice buttons and a decent alert system because we know that the main things will stop working.

              Comment


              • #8
                Hello, Joana

                We really appreciate your contact.

                A new version, which contains several fixes, was released yesterday and I can see that they are related to the issues you're facing.

                Please, update your version and tell me if the problems were solved.
                Last edited by robertoferraz; 09-06-2019, 02:45 PM.
                Best Regards,
                Roberto Ferraz

                Bug Tracker Team
                Netmake - IT Solutions

                Comment


                • #9
                  Hello Roberto,

                  We have seen it, but now we will remain in version 9.3 (which cost us a lot to return) after being completely blocked for many days by having installed version 9.4.003 and without any response from you.

                  We have a lot of late work and we are not going to try the new version in all our applications.

                  So far, we waited a few weeks to install your new versions, since we had already experienced some problems, but from now on I think we will wait a few months since this time it has been a real disaster and it has greatly impacted us.

                  We believe that your tool is very good, very useful and powerful, but you have a serious problem with the updates and it is a shame.

                  It CANNOT be that the things that work in a previous version stop working in the new one.

                  Regards

                  Comment

                  Working...
                  X