No announcement yet.

DEAR NET MAKE SUPPORT - this is my 3rd attempt to fix it !

  • Filter
  • Time
  • Show
Clear All
new posts

  • DEAR NET MAKE SUPPORT - this is my 3rd attempt to fix it !

    I'm having issue with SC7.1 running remote updates.
    I Tried to get help on the forum, but so far no one was able to figure out how to fix it.
    I also tried to get help from NM Customer Support, but while in the middle of conversation I was cut off from the support (because the system says my support has expired).
    As I'm not planning to pay NetMake for support while working on fixing SC bugs, I'm hoping somebody can again take a look and help me, although this might be also internal SC issue and the only solution is to get NetMake to fix it.

    The problem:
    when running SC updates I get the following error:

    Search for Available Updates

    Analyzing system files...

    Searching for available updates...
    Done. The requested service is inaccessible. It might be temporarily down. Verify your Internet connection.

    Amazingly I tried SC6 (I still have it installed on my PC) and got no errors ! In this case it seems that it is not the issue with my PC but rather with SC7 or NM server.
    When talking to the Customer Support I was told to do the manual update. Yes - I can do it once, but every few days, since NM sometimes releases updates more than once a week.

    I really hope somebody from Net Make will participate in this thread.

    Any suggestions highly appreciated.

  • #2
    This happens to me also ALL the time. I am a new SC user so cannot try it with a prior version.

    I have other problems and as you aka, I will not pay support for the privilege of reporting bugs.


    • #3
      How about installing fiddler2 the https web debugging proxy to see what is exactly going wrong? With that one you can see your https traffic as well. Maybe that tells a bit more why it is going wrong.


      • #4
        I was going to upload the LOG files but this stupid forum does not allow to upload anything other than image. When tried to paste the LOG into message it says there is to much text. Ohhh my.... what a crap! :-(

        here is a request location:

        /scriptcase/tmp/sc_js_AdminUpdate_688a80b17921498af43ed7701025f46c .js

        here is what is sent when the UPDATE button is pressed:

        var nm_url_compat = "/scriptcase/devel/compat/"; var nm_url_iface = "/scriptcase/devel/iface/"; var nm_win_name = "42665cb2"; function nm_upd_info(str_id, str_file) { document.getElementById(str_id).innerHTML = str_file; } function nm_upd_download() { document.getElementById("idArqPerc").innerHTML = file_perc; document.getElementById("idArqBar").width = file_width; } function nm_xml_read(int_size) { file_down = int_size; int_perc = Math.floor((100 * file_down) / file_size); file_perc = (100 < int_perc) ? 100 : int_perc; int_width = Math.floor((250 * file_down) / file_size); file_width = (250 < int_width) ? 250 : int_width; nm_upd_download(); } function nm_upd_file() { document.getElementById("idArqName").innerHTML = file_name; } function nm_upd_total(tot_perc, tot_width) { document.getElementById("idTotPerc").innerHTML = tot_perc; document.getElementById("idTotWidth").width = tot_width; }

        what would I look for in FIDLER2 ?
        Last edited by aka; 12-19-2013, 07:57 PM.


        • #5
          That thing you posted is a piece of a javascript. Sadly enough a dump is BIG (generally) and you need some tech insight in order to understand it..

          Fiddlers shows you the connection being made and thus also where there is no connection being made. It is basically a http/https debugging proxy (for chrome or firefox). So basically I hope you can at least see that
          there are some attempts made to go to the outside. My hope is that you may see some info where it could go wrong in the beginning steps.
          Tho I think the scriptcase code itself does a connect to the outside world probably via https. So if you really need the detailed info you may need to install the microsoft network monitor as well on your server (so do it in an off time!!). At least then you should be able to see what exactly goes wrong... Be aware this is highly technical.... I personally think scriptcase should actually add a log of any update attpemt, specially the ones that go wrong...
          Alternatively you maybe could activate logging. I didnt test that (see but that is where I would look... Since there has to be a reason.
          I also think that scriptcase could help by simply giving the url from where the files can be grabbed that way you should be able to see if you can even reach that url from your server.......


          • #6
            Just to confirm, it happens when i am trying to update too.



            • #7
              Hello guys,

              Our update server has had a few downtimes lately but we are working to fix it.

              This issue can also happen due to some software blocking apache's/iis's requisition to update ScriptCase such as a antivirus. A few of our brazilian customers were having problems due to Avira.

              Bernhard Bernsmann


              • #8
                Why doesn't sc make the updates also downloaded able and self extracting??

                Stupid questions


                • #9
                  Agree - that would be much easier and safer. Less trouble for NetMake. The fact that this problem has been bitten up many many times is very discouraging. I cannot run updates for several months and I would like NET MAKE either fix it or give me my money back.



                  • #10
                    if the problem lies in a server ?

                    Without changing anything I tried SC update today and all of the sudden - voila! It worked!
                    That means the problem was fixed on NetMake side. Now I asking the question why did I spend numerous hours with Customer Support, posting on forum and pulling my hair out, trying to figure out the problem ???

                    the naswer is simple: IT HAPPENED BECAUSE OF NETMAKE IGNORANCE

                    Last edited by aka; 12-28-2013, 06:04 PM.


                    • #11
                      Still not working for me unless I disable AVG.