Announcement

Collapse
No announcement yet.

Can't login to SC Development

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't login to SC Development

    I have a major problem. I can not login into my scriptcase development environment. Yesterday everything was working fine. Today I tried to login and I got this message.

    ADONewConnection: Unable to load database driver ''

    Fatal error: Uncaught Error: Call to a member function Connect() on boolean in /opt/NetMake/v9/wwwroot/scriptcase/devel/lib/php/database.inc.php:491 Stack trace: #0 /opt/NetMake/v9/wwwroot/scriptcase/devel/lib/php/base_ini.inc.php(1281): nm_db_connect(Array, '/opt/NetMake/v9...', 1281, false) #1 [internal function]: unknown() #2 /opt/NetMake/v9/wwwroot/scriptcase/devel/lib/php/base_ini.inc.php(2): sg_load('CE7E8A614756C85...') #3 /opt/NetMake/v9/wwwroot/scriptcase/devel/iface/login.php(25): include_once('/opt/NetMake/v9...') #4 [internal function]: unknown() #5 /opt/NetMake/v9/wwwroot/scriptcase/devel/iface/login.php(2): sg_load('CE7E8A614756C85...') #6 {main} thrown in /opt/NetMake/v9/wwwroot/scriptcase/devel/lib/php/database.inc.php on line 491

    I found this post

    https://support.scriptcase.net/en-us...ase-s-database

    I followed the instructions and it worked the first time. However, I kept getting kicked out of the scriptcase once I was logged in to the development environment. Now when I try this same approach I get this message.

    Notice
    : Undefined index: install in /opt/NetMake/v9/wwwroot/scriptcase/config.php on line 460

    I am stuck and really need help. Any ideas please help.

    Here is a copy of my setup.
    PHP: 7.0.14, SourceGuardian: 11.1.0, OS: LINUX IP-10-0-0-60 4.9.32-15.41.AMZN1.X86_64 #1 SMP THU JUN 22 06:20:54 UTC 2017 X86_64, WEB Server: Apache/2.4.25 (Unix) OpenSSL/1.0.1f mod_fastcgi/mod_fastcgi-SNAP-0910052141, ScriptCase Devel: 9.2.010, ScriptCase Build: 5, ScriptCase Prod: 9.2.010









  • #2
    If you are able to login once and create a full backup of your projects, then I would make a binary backup from your scriptcase folder. Next I would do a full re-install, re-register and load the backup. At least you are in the situation that should work. If it doesn't then you should get into contact of SC somehow unless you have installed (linux) updates that you might need to revert.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      I one time I was able to login I tried to make a backup and it failed. Now I can not even login at all. if I copy the project from the app folder on the server can I use it as my backup?

      Comment


      • #4
        depends what you mean by BACKUP.
        SC stores backups in its own internal format so if you would want to re-import it to SC it will not work, but if you would want to copy this into another machine and just run it - it will.

        Comment


        • #5
          The main confusion is that you can make a full backup, you can export a project etc. You must use the appropriate import function to let it work. If you do a full backup from within scriptcase you can import it after crash, I have done that before. But I always make a full binary copy (snapshot) so I can revert if things go wrong.
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development
          www.scriptcase.eu / www.scriptcase.nl

          Comment

          Working...
          X