Announcement

Collapse
No announcement yet.

Total chaos on running in linux server- BADBADBAD

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Total chaos on running in linux server- BADBADBAD

    I noticed that the behavoir of an SC-application is totaly different when putting it on a linux server. I am forced to install a windows server. THIS IS VERY BAD
    This after the latest update of SC before it was fine...


    SO NEVER UPDATE SC BEFORE TESTING INTENSIVE
    Last edited by ctmservice; 12-01-2018, 11:22 AM.

  • #2
    Again I found differences in the behaviour on a linux server.
    Has anybody the same?

    Comment


    • #3
      I have some issues in production that I don't have in dev and I'm running the dev and production environment on the *SAME* linux server.

      The differences are the apache and php versions: in dev apache and PHP are the NetMake provided ones while in production they are the OS provided ones.
      The server is running Fedora 27 so HTTPD and PHP are more up to date than the ones provided by NetMake.

      Not 100% sure, but more than the server OS, having the same PHP version in dev and in prodution should lower the risks

      Comment


      • #4
        Thank you for your reply. Yes their could be some differences on server side, that was also my first reaction. So I spendid a few days to setup an other server and with the same PHP. The issues came out after the last SC-update. Before it was ok...except an insert into..query. Besides a sc_redir gives many troubles. In the moment I have no idea how to solve it. I will loose a customer and hopefully without a claim. The thing I could do is to setup a windows server, but that is not cheap. I realy hope the developement team will pick it up. Regards Bert

        Comment


        • #5
          Bert, have you verified that you are running the same PHP version? Especially higher than 7.0.
          Albert Drent
          aducom software netherlands
          scriptcase partner, reseller, support and (turn-key) development
          www.scriptcase.eu / www.scriptcase.nl

          Comment


          • #6
            When I do the command in the terminal of my linux server: php -v
            then this commes out:
            See photo below....

            Comment


            • #7
              Hi there, I suggest you check the php version using phpinfo()
              you need php7 for scriptcase 9

              Comment


              • #8
                Run php 7 with SC9, last time I tried php 7.1 and it crashed my SC installation on the server. Luckily, I had a backup of everything. I'm currently running a server with Debian GNU/Linux 8.11 (jessie) with no real problems. Hope that helps.

                Comment


                • #9
                  I think indeed it is the PHP version. I have debian 7 and hope to get upgrade to PHP 7. I am not an expert on this. How to do this....?

                  Comment


                  • #10
                    To be sure not to have problems, do not exceed the php 7.0xxx version on the development, and most importantly, keep the php version 7.0 on the production, because I made the bad experience of many mistakes, one. com forced me every half hour in 7.2 (while my site is in full production, (school site with encoding points, etc.)), I went to scriptcase.net (OVH), at least we can manage php versions , some like one.com force to upgrade to version 7.1 or 7.2 while nothing is stable in the last two versions, this is for experience, not as advice, everyone makes his choice.

                    Comment


                    • #11
                      Ok thanks for your reply....

                      Comment


                      • #12
                        I upgraded to PHP 7.015 But the problems are not solved. It must be something in SC
                        Getting crazy...

                        Comment


                        • #13
                          More and more I come to the concusion, the last version 9.2.016 IS NOT stable for running in Linux servers.
                          When I develop on my windows 10 laptop and deploy it to a linuxserver there is a big change that there are functions which does not run.
                          That is very tricky because in your DEV-environment everything is ok, but not on the server. I spended days and days and nights and could not satisfy my customer.

                          Comment


                          • #14
                            Hi Bert,
                            Have you checked the functions that are going wrong? One of the possibilities is, that some php modules are not set active causing mishaps.
                            Albert Drent
                            aducom software netherlands
                            scriptcase partner, reseller, support and (turn-key) development
                            www.scriptcase.eu / www.scriptcase.nl

                            Comment


                            • #15
                              Hi Albert, Yes this could be the case. I am not an expert on linux. Somebody has to help me. The only thing is that before updating to the last SC version I had no problems.
                              2 Ways to go: Downgrading SC version or Have good setup of my linux server. (PHP settings?) Downgrading blocks me for the future updates. So the best is to have a look at my linux server.
                              Do you have somebody who can look over my shoulder......In a few minute I can lead him/her to the info of the server and the php.ini
                              Would be great, Regards Bert
                              Last edited by ctmservice; Yesterday, 11:32 AM.

                              Comment

                              Working...
                              X