Announcement

Collapse
No announcement yet.

[URGENT] Scriptcase 9.4.003 update is BROKEN

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [URGENT] Scriptcase 9.4.003 update is BROKEN

    I just updated after being prompted to do so, Scriptcase to the latest 9.4.003 version and now our whole project is broken.

    After 30min analyzing everything, the first thing I noticed is that ALL the CSS where the selector was "#idName", are broken.

    Apparently Scriptcase doesn't recognize ID selectors anymore.

    As soon as I change the selector from #idName to .div#idName , it starts working again.

    This is a major issue, as we have thousands of lines of CSS using ID's in our 110 apps project.

    Then other bugs are happening, like "TABS" have stopped working, you click on a tab and it doesn't switch to it (yesterday with the previous version of SC everything was working as intended)


    Please look into this ASAP and can someone explain to me how can I go back to the previous version??

  • #2
    I agree its broken. I'm still waiting for my bug reports to be dealt with before I upgrade.

    If you don't have a backup of the previous development folder, then it might work to export your project from 9.4 and import it back into 9.3.

    Comment


    • #3
      Originally posted by rperrett View Post
      I agree its broken. I'm still waiting for my bug reports to be dealt with before I upgrade.

      If you don't have a backup of the previous development folder, then it might work to export your project from 9.4 and import it back into 9.3.
      do you have the same issue with the CSS ID selectors?

      Anyway I tried to replace in my installation folder all the content of the 9.4.001 version, but when I start scriptcase, it s still 9.4.003, so it didnt work!

      Comment


      • #4
        Try to do a manual update of SC9.4.003, you can download the zip file from sc website and replace your current files to update.

        Comment


        • #5
          I do not think that it is a good solution, to make an update again with an old version, because new files will not be erased if they did not exist of this version .003, and if the problem comes from these files, so that might amplify the problem rather than solve it. the best solution being in the hands of scriptcase developers who might create a retroactive patch if you ask them.
          Last edited by nsch2308; 08-22-2019, 09:43 AM.

          Comment

          Working...
          X