Announcement

Collapse
No announcement yet.

Help - Updatefunction

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help - Updatefunction

    When a new Version is available i click the button and within a second i am up to date...

    When i then go to Helpp update -> check ScriptCase Update -> search for updates scriptcase found (9.00.007) 51 Updates.

    Now i press "download and update"
    Every time ( no matter what version) he downloads files...

    Then we come to p.E. 45%
    prod/third/jquery_plugin/calculator/jquery.plugin.min.js (1

    and scriptcase stops and i have no updates.

    Whats wrong?
    (there is no antivirus or something else - i have installed scriptcase as vhost on my centos server)
    Firewall rulez are all ok


  • #2
    I solved the problem...
    In V 9.00.000 it was possible to install scriptcase9 as vhost - i mean a REAL vhost

    that means:

    >>sc9.xxx.com<< and not >>sc9.xxx.com/scriptcase<<


    In 9.0.007 this is no longer possible - if you have an existing installation update failed...

    In addition i have secured it with htpass (not in the LAN - you must adjust your host file)
    I deactivate apache security - only problems.

    if someone needed it (centos7 - apache2.4):




    Code:
    <Virtualhost *:80>
    ServerName sc9.xxx.xxx
    ServerAlias sc9.xxx.xxx
    ServerAdmin webmaster@xxx.xx
    DocumentRoot /var/www/html/scriptcase9/
    
    CustomLog "/var/www/html/logs/scriptcase9.access.log" combined env=!forwarded
    ErrorLog /var/www/html/logs/scriptcase9.err.log
    
    
    RewriteEngine On
    RewriteRule ^/?$ /scriptcase [R]
    
    
    <IfModule mod_security2.c>
      SecRuleEngine Off
    </IfModule>
    
    
    <directory /var/www/html/scriptcase9/>
    AllowOverride all
    
    <RequireAll>
      <RequireAny>
        AuthType Basic
        AuthName "please login"
        AuthUserFile /etc/htpass/users
        Require valid-user
        AuthGroupFile /etc/htpass/groups
        Require group admins
          <RequireAny>
            Require ip 10.100.10.183
            Require ip xxx.xxx.xxx.xxx
            Require ip 10.100.10.10
          </RequireAny>
      </RequireAny>
    </RequireAll>
    
    </directory>
    </VirtualHost>

    Comment


    • #3
      In my case, it doesn't load anything, I just get an error message

      fclose() expects parameter 1 to be resource, boolean given | Script: /home/cnxm/public_html/sc/devel/class/page/nmPageAdminUpdate.class.php linha: 1181

      Did anyone have a solution for that

      Version 9.0.007



      Comment


      • #4
        Hi,

        I also receive a message like that message when starting an update.

        fclose() expects parameter 1 to be resource, boolean given | Script: /home/sc9/public_html/scriptcase9/devel/class/page/nmPageAdminUpdate2.class.php linha: 1521

        It look likes some kind of pemission issue. What resource could not be openen?

        Installed version 9.00.0031
        Last version 9.00.0037





        Comment


        • #5
          i also can not update, just hang there

          ver 9.00.0043
          Last edited by kakibox; 04-06-2018, 02:23 AM.

          Comment


          • #6
            I am getting the same with updating 9.1.003 and 9.1.005.

            fclose() expects parameter 1 to be resource, boolean given | Script: /home/dev91cbhc/public_html/scriptcase91/devel/class/page/nmPageAdminUpdate.class.php linha: 1264

            Comment

            Working...
            X