Announcement

Collapse
No announcement yet.

License activation error on new server with SC9

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • License activation error on new server with SC9

    Hi,

    We have an open ticket with the technical team of SC but they don't tell me anything, I want to share it with you in case there is someone else with this problem.

    We have migrated SCRIPTCASE to a new server whose characteristics are almost identical, at the time of activating the license, there is no way, it continuously tells us that the license is not correct, here the Server Differences:

    NEW SERVER VPS

    CPU Intel Xeon Virtual CPU (2 core(s)) – 8GB
    Ubuntu 16.04.6 LTS + Plesk Onyx v17.8.11_build1708180301.19
    Versión PHP: 7.0.33 - with Apache and extension=ixed.7.0.lin
    Linux vps6.iswolk.com 4.8.0-45-generic #48~16.04.1-Ubuntu SMP Fri Mar 24 12:46:56 UTC 2017 x86_64
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.1, Copyright (c) 2002-2018, by ionCube Ltd.
    with Zend OPcache v7.0.33, Copyright (c) 1999-2017, by Zend Technologies
    with SourceGuardian v11.3.2, Copyright (c) 2000-2019, by SourceGuardian Ltd. -> Installed on the recommendation of SC technicians (although it is not on the server that works)

    OLD SERVER VPS WHERE SC WORKS

    CPU QEMU Virtual CPU version 2.5+ (4 core(s)) – 4GB
    Ubuntu 16.04.6 LTS + Plesk Onyx v17.8.11_build1708180301.19 (Licencia gratuita en prueba)
    Versión PHP: 7.0.33 - with Apache and extension=ixed.7.0.lin
    Linux cloud6.iswolk.com 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.1, Copyright (c) 2002-2018, by ionCube Ltd.
    with Zend OPcache v7.0.33, Copyright (c) 1999-2017, by Zend Technologies

    SYMPTOM

    Once the files between servers have been copied and the folder permissions reviewed and the hosting environment configured, it is verified that this application can be accessed without apparent problems, but when modifying the server's IP, the application detects it and asks you to request the activation of a new license (ok new licence to install in SC portal), it is just at this time when trying to activate the application when an error appears that the license is not valid, the first contact has been with the SC support service, once the permissions have been analyzed, routes etc ... tell us that there must be some difference with the hosting that makes it impossible to validate the license. Both the old and the new server have the same ports open in FireWall.

    We have performed all the checks and installations mentioned in these entries but without success:I want to make it clear that SC works perfectly on the new server with a clean installation but a 15-day trial license, at the time you try to activate the license, ERROR the license number is not valid

    Can anyone contribute any ideas?

    Thanks in advance
    Last edited by jad; 09-21-2019, 06:06 AM. Reason: SOLVED

  • #2
    Hi,

    The problem has been solved by SC technical support, there is a problem with version 11 of SourceGuardian, solution:

    You have to copy the SourceGuardian module that has happened to me from SC (ixed.7.0.lin) to apache and restarted the service, at first I could not access scriptcase with the error:

    2019-09-21 10:37:42 Error AH01067: Failed to read FastCGI header Apache error
    2019-09-21 10:37:42 Error (104) Connection reset by peer: AH01075: Error dispatching request to: Apache error

    The hosting where Scriptcase is had PHP running in FPM mode served by Apache, with this configuration the SourceGuardian module SC fails but if we run PHP in FastCGI mode served by apache, then everything works correctly.

    Instead, your diagnosis shows that SourceGuardian is not active (same as in the old server), and this is so because to use SourceGuardian, PHP must be executed in FPM mode.

    Thanks to the technical service of SC especially to Juan for solving the problem, even if provisionally until they find a solution.

    Comment

    Working...
    X