Announcement

Collapse
No announcement yet.

[SOLVED]Create new form

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GhoulRul
    started a topic [SOLVED]Create new form

    [SOLVED]Create new form

    I recive error when create new form whit the table

    HTML Code:
    CREATE TABLE `odp_graficos` (
    	`id_odp` INT(5) UNSIGNED NOT NULL,
    	`nombre_a_i` VARCHAR(255) NOT NULL COLLATE 'utf8_spanish2_ci',
    	`tamano` DECIMAL(10,9) NOT NULL,
    	`id_grafico` INT(6) UNSIGNED NOT NULL AUTO_INCREMENT,
    	PRIMARY KEY (`id_grafico`),
    the error say me to this:

    HTML Code:
    Invalid argument supplied for foreach() | Script: C:\Program Files (x86)\NetMake\v71\wwwroot\scriptcase\devel\compat\nm_aplicacao_cria.php linha: 616
    For that check that file and find no php file
    open file with noteblock an find bad file archive with this

    HTML Code:
    <?php @Zend;
    3074;
    /*  ٌ!This is not a text file!قي   */
    print <<<EOM
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"><HTML><HEAD></HEAD><BODY LANG="en-US" DIR="LTR"><H2 ALIGN=CENTER>Zend Guard Run-time support missing!</H2><P>One more more files on this web site were encoded by <A HREF="http://www.zend.com/products/guard">ZendGuard</A> and the required run-time support is not installed orproperly configured.</P><H3>For the Web site user</H3><P>This means that this Web server is not configured correctly to runthe files that it contains. Please contact the Web site'sadministrator/webmaster and inform them of this problem and give themthe URL you are trying to display to help them in diagnosing theproblem.</P><H3>For The Site Administrator/Web Master</H3><P>One or more files on your site were encoded with Zend Guard. Thismay be third party libraries that were provided to you by an ISV. Toallow these files to properly run you need to download and installone of the Zend guard run-time libraries. This is either ZendOptimizer or Zend Loader. The proper files can be downloaded from<A HREF="http://www.zend.com/guard/downloads">http://www.zend.com/guard/downloads</A>.This software is provided free of charge.</P><P><B>General Disclaimer:</B> Zend Technologies is not responsible tothe configuration and setup of web sites using Zend Guard technology.Please contact your software vendor if these components were providedby an ISV or consult your Zend Guard Users Guide if these files wereencoded by your organization.</P></BODY>

  • kunjan
    replied
    i also get below error when i host my site on a hosting company on linux shared hosting
    Zend Guard Run-time support missing!

    Leave a comment:


  • John L. Santos
    replied
    Hello,

    The problem is in your CREATE. Is there any invalid character in your CREATE, see picture bellow.

    create.png









    Use the CREATE below:
    Code:
    CREATE TABLE `odp_graficos` (
        `id_odp` INT(5) UNSIGNED NOT NULL,
        `nombre_a_i` VARCHAR(255) NOT NULL COLLATE 'utf8_spanish2_ci',
        `tamano` DECIMAL(10,9) NOT NULL,
        `id_grafico` INT(6) UNSIGNED NOT NULL AUTO_INCREMENT,
        PRIMARY KEY (`id_grafico`)
    )

    Leave a comment:


  • GhoulRul
    replied
    I'm tried for another name of table and its fine now. this is the new table

    Code:
    CREATE TABLE `odp_documentos` (
    	`id_documento` INT(6) UNSIGNED NOT NULL AUTO_INCREMENT,
    	`id_odp` INT(5) UNSIGNED NOT NULL,
    	`id_tipo_doc` INT(2) UNSIGNED NOT NULL,
    	`documento_nombre` VARCHAR(255) NOT NULL COLLATE 'utf8_spanish2_ci',
    	`tamano_documento` FLOAT NOT NULL,
    	`documento` MEDIUMBLOB NOT NULL,
    	`fecha` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP,
    	PRIMARY KEY (`id_documento`)
    COLLATE='utf8_spanish2_ci'
    ENGINE=InnoDB
    The table is really the same at the last, only name changes, but it work fine
    Last edited by GhoulRul; 01-28-2015, 02:06 PM.

    Leave a comment:


  • rr
    replied
    Try to remove the COLLATE .... maybe then it woeks..
    Anyway the standard php from scriptcase is zend encoded.. So the only ones that can resolve the bug is netmake itself... So this is a bug in view..
    Please add the scriptcase version number you use in here too.

    Leave a comment:

Working...
X