No announcement yet.

ScriptCase v8.0.022 Bug in user mode Security module and Applications

  • Filter
  • Time
  • Show
Clear All
new posts

  • ScriptCase v8.0.022 Bug in user mode Security module and Applications

    I have a users table, and generating the User mode security on that table relies on a code generation error in the event onValidate on app_Login.
    The "onValidate" SQL query goes wrong, my field is "password" and in that specific query the password field remains as "passw", it's easy fixable, but....

    GRID or Form with use mode security enabled does not shows on menu... tried different ways to solve it with no luck, can't make it show up, can't deploy that app because this...
    If I disable security in grid or form it shows up...

    The other thing wrong is that "Hide menu items" is off, so... it should appear as disabled, but no.
    Last edited by maurirp; 12-05-2014, 01:37 AM. Reason: forgot about something

  • #2
    Nobody? Can't find a workaround for this!!!

    Should I need to make my own security module to make it work?

    This is the grid

    When I disable the security in the grid, it shows up

    When I enable security in the grid, it dissapears, even when in menu config "Hide menu items" is disabled WTF!! at least it should be disabled!! GRIDS, FORMS, all dissapear!!!


    • #3
      Have you set permissions to the context user to access that app? Have you tried clearing your browser cache?



      • #4
        There is no app access context, the user mode security has only one table, users.


        User - Security level where the application is connected to user login, this level of security the user has access to all system applications.

        Application - Security level where the application relates to the user, this level of security the user only has access to certain applications.

        Group - Security level where the application relates to a group, this level of security is defined access each group a certain number of applications and each user is belonging to a group.

        LDAP – Look this documentation about LDAP


        • #5
          This is my user $_SESSION content about security module

          [nm_session] => Array
          [lang_debug] => 0
          [sc_version] => v8
          [user] => Array
          [login] => admin
          [cod_grp] => SMATAEmpresa
          [cod_ver] => 1
          [des_ver] => 1.0.0
          [folder] => root/seguridad
          [lang_direction] => LTR
          [sc_path] => C:/NetMake/v8/wwwroot/scriptcase/
          [sec] => Array
          [flag] => Y
          [pass] => Y

          [parallel_compiling] => 1
          [friendly_url] => S
          [sc_project] => N
          [folder_open_type] =>

          [flag] => Y should be [flag] => N to show menu entries, but i couldn't find where it is set


          • #6
            Originally posted by maurirp View Post
            There is no app access context, the user mode security has only one table, users.

            I meant to ask you if you have set permissions to the user accessing the app, on that application.



            • #7
              Wait, do you really understand "User" mode security?
              There is only one table, a users table!!!! There is o way to set permission on applications!! That should be "Aplication" security mode!!!!


              • #8

                Issue reported to our bugs team.

                Bernhard Bernsmann


                • #9
                  Still waiting, 3 updates, but nothing about this....

                  Can't deploy my applications!!!!!!!!!!!!


                  • #10
                    I've tested some other security modes and discovered the problem and the solution, still a BUG...

                    Problem: All menu options after applied security module, dissapearing. The problem is security module messed up when "Friendly URL" is applied on applications.
                    - In user mode security option dissapeared, because is using on some code the friendly url name and not the aplication name.
                    - In Aplication security mode, after aplication syncronization, option does not shows. In sec_apps table the field "app_name" is generated with friendly url name and not with application name and "app_type" is blank.

                    There is some function or code on security module that uses friendly url name as application name and not the real application name and it generates this kind of problems.

                    Temporary solution: Disable friendly url on all aplications!!!!

                    I hope this guides netmake developers to a faster bug fix. Thank you Bernhard


                    • #11
                      have noted that....
                      My greatest fear of using SC is that i am about to embark on a big government project. If i stall or get stuck with a bug and netmake takes too long to fix it or give constructive advice, i'll be ruined.
                      If i buy support is there a guarantee that my problems will be fixed rather than this usual issue reported to our bugs team.


                      • #12
                        lol, lol, lol
                        Dave Prue
                        Code Whisperer
                        Lahar International Corp


                        • #13
                          A serious answer: we develop serious applications with thousands of users. There has been and always be bugs. That counts for every tool. If you are prepared to find work-arounds now and then, then you are save imho. If you persist in a certain solution then you might not have found the right tool, but on the other hand I doubt if any tool would be able to give those guarantees. Just my few cents.
                          Albert Drent
                          aducom software netherlands
                          scriptcase partner, reseller, support and (turn-key) development