No announcement yet.

[SOLVED] Error attempting to Deploy Application via SFTP

  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] Error attempting to Deploy Application via SFTP

    Built with v8
    SC Development Enviroment is patched to 8.0.36
    Web Browser: Firefox 36.0
    ServerOS: Zentyal 3.3.10 based on Ubuntu 12.04 - PHP 5.4

    When I attempt to deploy an application via SFTP, I get the following error:

    Fatal error: Call to a member function chdir() on a non-object in /opt/NetMake/v8/wwwroot/scriptcase/devel/class/page/nmPagePublishWizard.class.php on line 1191

    Undefined variable: obj_ftp | Script: /opt/NetMake/v8/wwwroot/scriptcase/devel/class/page/nmPagePublishWizard.class.php linha: 1191

    Works fine if I manually download the ZIP file, then manually upload the application with Filezilla to my Production Enviroment, but I want to start using SFTP to streamline my process of publishing updated applications.
    Last edited by CurtisB; 03-27-2015, 11:52 AM.

  • #2
    It looks like an access issue. Possibly your ftp server doesnt have the rights to certain directories. You should turn on the logging in sftp (I hope this is the proper link: ) and see what is happening on the server side.
    Alternatively you can test your sftp server and upload a few files by hand with sftp and create a few dirs with some files in it just to test if it is working normally.


    • #3
      Hi CurtisB,

      The problem was solved. Please, update your scriptcase and test it again.
      Caio Guerra
      Scriptcase - Web Developer