No announcement yet.

Can't restore project

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I have had a HD crash some time ago. Now trying to restore some projects into SC8.1 (which were created with SC8 long before the crash).
    Cannot restore :-(
    ERROR: The file was noy created by Scriptcase version 8

    I TRIED 6 different files with the same unsuccesful result!!!

    and they say they improved backu/restore ? sounds like a joke!

    Any ideas ?

    Last edited by aka; 09-25-2015, 12:24 AM.


    • #17
      Likely your zip file is damaged. Unpack using the commandline and see if unpacking gives errors. If so then you can be sure that your zip file is damaged.
      You may be able to extract part of your project then but definitely not all.
      You may have a small chance or repairing your zip using ziprepair from diskinternals, but dont get your hopes up..


      • #18
        RR - thanks I will give a try manually unzipping the backup files, although it is hard to believe that all of them are damaged. I have about 12+ files and none of them can be restored.
        Yes I did the backup of full SC folder but that got lost when the HD crashed. The only files I have left are backups on CDs. Restoring to the previous SC version (which is 8) would be probably possible if I knew what subversion to use. I really have no idea what particular subversion was used to do specific backup (I have several files).

        I found a copy of the whole folder with the Apps for the whole project (I think this might be a production set), but I see no way to import it into SC. NetMake keeps saying they working on improving it but I see not even slight improvement for the last few years. I experienced those problems with SC5, they continue till today and of course I'm not the only one.

        When installin i.e SC8 and SC8.1 - how do you structure your folders? shall I have them like: SC8 - C:\ProgramFiles\Netmake\SC8 and SC8.1 - C:\ProgramFiles\Netmake\SC81 ------------- is this enough ?



        • #19
          Giu - thanks for your suggestions but Support is really useless. I just asked them for help. They asked me to email them my backup file (which in my case is about 80Mb). No email server will handle that. I have uploaded it to my FTP server and sent them all access info so they can download it. Gusess what ? They keep asking if I have emailed the backup file,...and they did it 3 times. NO COMMENTS!



          • #20
            One point that may help you...
            You may still have older versions on your crashed HD (assuming the crash is not a very severe crash). With some undelete tools (getdataback has VERY good tools, but there is some pretty good freeware too) you can recover files. It may be possible that you can recover a previous zip version. Do not write to that crashed HD in any way, any writing
            will make it harder to recover. If the hdd still spins which I assume you are likely to find many old versions back.
            Sadly enough you can not import a deploted project. You can only deduce the logic with a lot of work by inspecting the source code, and thus recreate the apps by hand..
            We have our directories in c:\Program Files (x86)\Netmake\sc8 (and sc7 and sc6).

            You can send them your backup file, all you need to do is put it on google drive and send them a download link or an even smarter alternative is to use wetransfer.
            You should announce that you are sending the file via wetransfer (or whatever you use) though. You can send a file of 2G via WeTransfer...

            Anyway to get back to data recovery, I've done some serious hdd recovery before (for MAC and for PC) . Assuming your drive is an NTFS drive for windows, chances are pretty great that it can be recovered using good software. Do not in ANY WAY try to write to the disc...!!
            Unless you have a head crash on the hdd, in which case you hear a scratching sound when that crashed drive runs.
            If the print board failed you may be able to find an old drive of the exact same type on ebay or other public online marketplaces...
            If the crash has been serious it may even be better to start up a linux with recovery tools like the systemrescueCD or ultimatebootcd.
            They have good tools too, tho I found getdataback to be the best windows tool for that work.
            In all this I assume you did make a an app backup sometimes in the past. Then the zip file could maybe be recovered.


            • #21
              rr - please stop talking about data recovery. This is not a point of the post.
              1. I have mentioned here I have had a backups on external HD, CDs , USB sticks etc which were made when everything worked fine. None of them can be restored. It is more than unlikely that out of 30-40 backup files all of them are corrupted.
              2. I send the backup set to my FTP sever. Posted all FTP access info as a reply to the ticket I created. Person who replies to the ticket seems to be blind. He keeps saying to email it to him. I asked 3 times if he can download it from my FTP sever (giving him server IP, username and password). He answered - YES. Then all conversation stopped. This is just insane!
              3. I can send the backup to Google Drive or DropBox or whatever if I could only have normal person start cooperating. So far dealing with support through the tickets is a pain on the but and it is as frustrating as it gets!

              Bottom line - I'm waiting already 4 weeks to get help
              results: NONE



              • #22
                I dont know that, I havent seen which files you have. Hence I could only answer based on the assumption that you had no proper files. So thus I gave you a way to be able to recoved some files of which some (with a little bit of luck) could be recovered.
                If you told me you had a unpacked backup zip file which can be extracted completely without any trouble then the story would be different.
                Then someone else can import that and see what happens..


                • #23
                  I send the same issue at september 9 / 2015 and continue waiting a solution

                  many people are reporting this bug



                  • #24
                    It is possible to change the database from a sybase version 8 to sybase 16, the connection is via odbc. As I can see the connection configuration parameters of the database, it is odbc connection.


                    • #25
                      Originally posted by Jena Matusen
                      now ONE YEAR LATER we have similar issue with SC9

                      Try a clean to SC. (cleaning the content of folder scriptcase/tmp, cleaning browser cache, restarting browser)
                      Professional Scriptcase Services
                      Support/Outsourcing/Mentoring for projects migration to Cuba-Platform