No announcement yet.


  • Filter
  • Time
  • Show
Clear All
new posts


    I have a form with SELECT field to pick a Timezone from another table. This is rather straightforward. I select a time zone and,... ahghghgh! get this error Timezone_error01.png

    The record structure is super simple Timezone_error02.png

    from the table below, when I select "Alaska" is works fine but when I select Central Time (red frame) I get the error above !

    I wonder if there is any bug in a validation field or anything that makes SC does not like brackets, colons etc....
    The vield is VARCHAR() so it should accept anything, right ?

    I did some testing and when I removed the ampersand symbol from the timezone record it works fine. I believe this is a bug and needs to be addressed.

    Last edited by aka; 05-12-2016, 08:36 PM.

  • #2
    Could be possible your charset on SC is different than on database?

    Anyway, you show where data comes from, but, can you show where data should be stored? DB field, how is configured your select field, and so on.
    Professional Scriptcase Services
    Support/Outsourcing/Mentoring for projects migration to Cuba-Platform


    • #3
      Giu - thank you for responding.

      It is definitely matter of what is stored in the SELECT record. When I remove semicolon or ampersand character it works fine. They only problem is if there is ; OR &
      so it is obviously not a problem with the SELECT settings. What do you mean by CHARSET for SC ? I use UTF-8 which is international and should accept all characters. The semicolon and & ad standard ASCII characters so they do not even belong to another language so I see no reason for those to be unacceptable.



      • #4
        Just curious as to why you chose to store the ampersand in the way you did? Why not just use the naked symbol?


        • #5
          ... I have just tried it with a user maintenance app that I have.
          Added a user " Ann & Persand" - it worked fine.
          Did a password reset through another SC app that produces a pick list from the existing users and that worked fine too.

          I tried it all again with "Ann & Persand" and that worked fine as well.


          • #6
            Thanks Shean. Did you use MySQLi to test it ? If so then I'm out of clue,....
            I have no idea then what is going on, but I noticed that after removing the & and ; from selection records it worked fine. Possibly there could be some database settings.


            • #7
              MySQL using MySQL PDO connection ...


              • #8
                MySQLi and MySQL-Pdo are not the same. I was just curious if this is an MySQL or SC issue