No announcement yet.

Show diagram not working on linux

  • Filter
  • Time
  • Show
Clear All
new posts

  • Show diagram not working on linux

    Hey guys:

    I wonder if any of you guys using SC on linux have the same problem, whenever i try to generate my project diagram i appears blank.


  • #2
    I don't think it ever did. Tried it quite some time ago didn't work back then either.



    • #3
      D=... well idk why but i kinda saw that coming lol.

      Thnk you man


      • #4
        SC assumes you have Graphviz installed on your linux server. If you are getting a blank screen then Graphviz isn't installed, so you need to install it - it's quick and easy:

        Basically - at your server's terminal command line....

        sudo apt-get install graphviz


        • #5
          thanks for the tip.
          I got it working on Centos by installing the program by running the command

          sudo yum install graphviz
          ************************************************** ********
          We are Developing your Future Business Requirement right now with Scriptcase.


          • #6
            Does not work on Scriptcase v8.1 Mac OS version as well

            I have installed Graphviz for MacOS using macport but scriptcase v8.1 still not able to access the graphviz application to show the diagram.
            Is there any other solution? Can Scriptcase improve on this ?

            Perhaps, as an alternative, Scriptcase could generate the dot file so that we can manually open it using graphviz

            I discover that the reason WHY it did not show the diagram is because it was looking for the generated file as an image sc_graph_xxxxx.png
            and the error msg was Failed to load resource: the server responded with a status of 404 (Not Found)
            The file was located in directory /scriptcase/tmp/.
            However, I found the in the same directory and manual use graphviz to open the dot file and export it to png and do a reload of the blank screen and the diagram is displayed.

            Attached Files
            Last edited by leatheric; 12-13-2016, 12:52 PM.


            • #7
              Works for me in ubuntu, via shell apt-get