Announcement

Collapse
No announcement yet.

"NEW" Link from grid to a form

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Joe
    started a topic "NEW" Link from grid to a form

    "NEW" Link from grid to a form

    Hi,
    how can I create a "new" link from a grid to a foreign form? If I create the link with the link function I'm always in update mode of the form.

    Joe

  • Giu
    replied
    Originally posted by Joe View Post
    Hi Giu,

    yes I do. I have already other app links under the "links" section.

    Joe
    ?

    You just can have one "Application" link under Links. Otherwise, If you have an Application entry under the tree menu on Links, then you can't create an Application link, because is created. Just click and configure at your needs.

    Leave a comment:


  • Joe
    replied
    Hi Giu,

    yes I do. I have already other app links under the "links" section.

    Joe

    Leave a comment:


  • Giu
    replied
    Originally posted by adz1111 View Post
    Joe

    You have to add the application link yourself by clicking on New Link in the Links section - and then choose the form you want to open a chosen grid record.

    The only time I believe you do NOT have to do this is if you choose to create potentially multiple applications through the batch process (although you can just choose to build 1). In that case you select from a list of tables and you can tick whether SC is to build a grid AND a form. If you select both, SC adds the application link for you as part of the build.
    Or maybe app link exists.

    Has you some "Application" with a blue arrow under Links and then, under Link?

    Leave a comment:


  • adz1111
    replied
    Joe

    You have to add the application link yourself by clicking on New Link in the Links section - and then choose the form you want to open a chosen grid record.

    The only time I believe you do NOT have to do this is if you choose to create potentially multiple applications through the batch process (although you can just choose to build 1). In that case you select from a list of tables and you can tick whether SC is to build a grid AND a form. If you select both, SC adds the application link for you as part of the build.

    Leave a comment:


  • jsbinca
    replied
    Originally posted by Joe View Post
    Also when I'm generating a new grid there is no application link available!!??
    I'm sorry, but I can't help on this one. I gave it some thoughts, but couldn't come up with an idea why
    this option is missing. May be one of the others does. I would suggest to start a new thread about it.

    jsb

    Leave a comment:


  • Joe
    replied
    Thanks jsb, it's amazing how you solve problems for newbies like me. I appreciate your help because this makes me learning - and thinking ;-)

    Joe

    PS: regarding the grid. Also when I'm generating a new grid there is no application link available!!??

    Leave a comment:


  • jsbinca
    replied
    Strange.
    Anyways, create a global variable i.e. [new_record].

    In the onApplicationInit event of the form:
    Code:
    if([new_record])
    {
        sc_appl_conf('yourform','start','new');
        [new_record] = 0;
    }
    Create your link as usual, when asked for the parameter to pass, set Fixed to 1.

    jsb

    Leave a comment:


  • Joe
    replied
    Hi,

    I don't get the option to create an application link only field and capture so I was trying a virtual field with an image link to the form application but this does not lead directly to the "new" mode of the form application.

    Joe

    Leave a comment:


  • jsbinca
    replied
    See here:
    http://www.scriptcase.net/scriptcase...rid/grid16.php -> Link Properties

    jsb
    Last edited by jsbinca; 06-08-2015, 10:27 AM.

    Leave a comment:

Working...
X