No announcement yet.

Master/Detail Strips Toolbar off my Detail Application

  • Filter
  • Time
  • Show
Clear All
new posts

  • Master/Detail Strips Toolbar off my Detail Application

    I have a single record form that loads a record to edit. Below that I added a Tab called contacts that has a Grid view of all the contacts associated to that original single record. Inside that grid I have another form as a modal that allows me to edit and create new contacts. When I build that grid stand alone it runs fine has the editing option on the side of each record and an Add Contact button at the top, however if I run my single Record Form with it in the iFrame Tab it strips off the edit symbol and Add contact button. How can I resolve this issue.

    Building Grid Alone:
    Screen Shot 2014-03-03 at 3.42.32 PM.jpg

    Building Form With Grid Detail
    Screen Shot 2014-03-03 at 3.42.53 PM.jpg

    Sterling Lutes

  • #2
    I have the same problem here, i need this behavior.


    • #3
      Ok, new to sc but I needed this functionality also, Here's what I've noticed: I had a single edit master form, with a detail in a tab, if I used a grid I could modify the table through the grid, but if I tried to use a form from the grid it did the same think you said, took away the edit option from the grid. What I did to get around this until I figure it out was to put a button on the main form linking my detail in another window. Kinda defeats the purpose of all the info on one screen but it works until I can figure out a way to get around this bug.

      Skype Id:


      • #4
        I have researched this on this forum....

        and it seems more than a few people have the same problem. Maybe its something we are missing in the setup of master/detail? On the bugs forum there is a post about this issue and netmake thinks it's not a bug. I think it may having something to do with how things are configured. That's one of the drawbacks (and advantage too) to a system like this, you don't know what's happening in the background.

        I will work on this tonight (because I've got to get it right) and see if I can get some more insight on whats going on.

        It works fine in my button. But not on the tab when set up as a master/detail option. Seems to me there is a bug but I have been wrong before.

        Skype Id:


        • #5
          Ok... Maybe its something that not normally done? I went through every SC tutorial example of how to setup master/detail and in every case the detail was edited on the grid. There were NO form calls in the grid in the examples.

          SO.... I don't know if this is the functionality (or lack of) or an unknown way of doing this, but SC needs to explain whether or not it is an option. THEY say its not a bug, but when my grid/form work perfectly on its on, then when I call it, it should work. Either in master/detail or anywhere else I call it. SO the bug is either on my end or theirs. SC Please advise....
          Skype Id:


          • #6

            I spent a couple of days doing the same way you all had done it until I realized what we are trying to do is impossible with Scriptcase.

            Basically we are all trying to link a editable Form to a Grid which linked to another editable Form.


            Fortunately, there is a way but it may not be what you want. In my case, it is acceptable.

            What I did is to do Form->Form skipping the middle Grid completely. The trick is to make the second Form as Editable Grid form.

            Let's say we have a master detail relationship between department and employee. A department may have 0, 1, or many employees. We also have created 2 forms: one for department and one for employee.

            Here are the steps to do link Form(Dept) -> Form (Employee):
            1. In the second form (employee) go to Settings->Orientation->Editable Grid (from the drop down menu)
            2. In the first form (department), create a new master/detail link to the second form (employee), specifying the linking relation (dept.dept_id = employee.dept_id)
            3. Lastly, on the link property sheet, enable the following properties:
            - Enable insert button on target application
            - Enable update button on target application
            - Enable delete button on target application
            - Enable navigation button on target application



            • #7
              Im having the same issue:!
              Even if I change it to editable grid the edit/pencil icon doesnt show. But everything works fine locally!