No announcement yet.

[SOLVED]Connection error when trying to set up a prod srv: error_profile_test_module

  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED]Connection error when trying to set up a prod srv: error_profile_test_module

    I am attempting to set up my first production environment with ScriptCase v7. When I first log into the ScriptCase Production Environment screen and enter my user name and password, the following error is displayed:

    Connection Error


    I don't even get the opportunity to select my schema or to click on the Test Connection icon. I tried doing a search on the above error in the forum, but it looks like ScriptCase Forum doesn't like names that long (even though it is THEIR error name!). It rejected my search. Using a shortened version of that error returned nothing.

    I have NO idea what to do at this point. Suggestions anyone?

  • #2
    Hard to tell. How did you create your deploy package? Does it have all the whisles and bells? (Runtime lib etc?). Did you change connections names? This is an odd error, never seen this before.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development /


    • #3
      Under which os are you trying??
      Lets assume you try on windows server (or windows 7 or up). Then netmake is installed in the program files (x86)/netmake dir.
      From there in the components dir your apache is installed somewhere. Check it in the local services, it should show your ApacheScriptcase service. If you want to connect to the outside world to a database
      somewhere else on another service then you need to connect using a user that can connect to the outside world. So change the properties of that service in the log on tab and add a user with more rights.
      If the database is running under Local System then you only have Local System access, so your database should be local as well. Then you shouldnt need that change.


      • #4
        Albert, thank you for your reply. I did a system-wide deployment and did not exclude any files or options. I had Scriptcase create a zip file for me. Is it possible that the deployment could have somehow been corrupted during the process? I ask this because I had to create a second deployment right after the first, for I found an empty folder for one of my applications. I discovered this when deploying to my development machine, so see just how the deployment process works (I am new at using Scriptcase) and to get an idea of what to expect when moving to a production environment. On that second deployment, I did not first test it on my machine, due to time constraints. (I should know better!) I have not yet tried to deploy it a third time, though I will probably attempt that, to see if doing so might resolve the problem.


        • #5
          I developed on a Windows 7 environment, but my production environment is Mac OS X (Maverics). (My Mac development machine's OS was too old for Scriptcase to install and work properly.) For now, the production environment is in-house only, and my initial setup was for just that local machine only, to take it one step at a time. My database is MySQL. For ease of installation and based on many comments from other forum members, I used AMPPS for laying down Apache, PHP, and MySQL. I did set the PHP option to 5.4.x.

          The strange thing is that the production screen does not even wait for me to enter a user name and password before displaying this error. Of course, it had already connected to my database or I would not made it to that screen.

          Very strange indeed. I just replied to Aducom, and asked if my deployment zip file could have somehow become corrupted during the deployment process. I will create a new full-system deployment, to see if the problem persists. In the meantime, any additional suggestions are GREATLY appreciated!


          • #6
            Try a zip deployment, unzip over a local server (using WAMP, Uniserver, or whatever server you prefer), and check if works. Then, try with same zip over your Mac machine. This is to discard Mac specific problems.

            Professional Scriptcase Services
            Some Customers opinions


            • #7
              I found the problem. The scriptcase zip file was corrupt. When I generated a fresh deployment (using all the same default options for a complete deployment), the new zip file installed and worked perfectly. Thank you everyone for your assistance!