No announcement yet.

Retrieve Password App SC - "ERROR: Array to String Conversion Array"

  • Filter
  • Time
  • Show
Clear All
new posts

  • Retrieve Password App SC - "ERROR: Array to String Conversion Array"

    I'm having this issue (error message in Title) using SC (and was having the issue with earlier versions of SC 8) BUT, at one point with SC 8 it DID work, without the error message. At some point, and I don't know when exactly, it started giving the error message. The error message happens in the SC development environment when I RUN the application.

    The error message also happens in the production environment. I've recently moved the site where this issue exists to a new server, but I don't know if there was an issue before the move or not. I'm going to try to find out. In the meantime, this error (Array to String.....) was supposedly fixed at some point in SC 7 (there is another thread about it in the SC 7 Forum) but I'm having the problem in SC 8. The error message even happens in the SC development environment when I RUN the application.

    Does anybody have a clue as to what is going on here?

  • #2
    Can tou share application settings tan, and onLoad, OnAppInit and so on .. Screenshots?

    Professional Scriptcase Services
    Some Customers opinions


    • #3
      Yes, here are the scripts for onScriptinit and onValidate as well as all the PHP methods. These are all pretty much out-of-the-box when installed the Security apps within SC 8. And as I said, it was working fine for quite some time.

      Thanks in advance for any help. I've added 5 images in this post and the rest in the next post.


      • #4
        And here are the rest of the PHP methods screenshots.


        In my database, "name" is the username, "pass" is password, "mail" is email address. The form field is "login" - user submits username="name".

        Hope this helps.


        • #5
          OK, a few minutes ago when I tried the application on the production server, I get this error message:

          Fatal error: Uncaught exception 'Swift_TransportException' with message 'Failed to authenticate on SMTP server with username "" using 2 possible authenticators' in /home/xxxxxxxx/public_html/vrs/_lib/prod/third/swift/classes/Swift/Transport/Esmtp/AuthHandler.php:176 Stack trace: #0 /home/xxxxxxxx/public_html/vrs/_lib/prod/third/swift/classes/Swift/Transport/EsmtpTransport.php(307): Swift_Transport_Esmtp_AuthHandler->afterEhlo(Object(Swift_SmtpTransport)) #1 /home/xxxxxxx/public_html/vrs/_lib/prod/third/swift/classes/Swift/Transport/AbstractSmtpTransport.php(124): Swift_Transport_EsmtpTransport->_doHeloCommand() #2 /home/xxxxxxxx/public_html/vrs/_lib/prod/third/swift/classes/Swift/Mailer.php(79): Swift_Transport_AbstractSmtpTransport->start() #3 /home/xxxxxxx/public_html/vrs/reset-password/sec_retrieve_pswd_apl.php(2068): Swift_Mailer->send(Object(Swift_Message), Array) #4 /home/xxxxxx/public_html/vrs/reset-password/sec_retrieve_pswd_apl.php(1998): sec_retrieve_pswd_apl->send_mail_ in /home/xxxxxx/public_html/vrs/_lib/prod/third/swift/classes/Swift/Transport/Esmtp/AuthHandler.php on line 176

          Then it went back to the "ERROR: Array to String...." message.
          Last edited by rjjacob; 07-14-2015, 01:22 PM.


          • #6
            The Fatal error has to do with the SMTP authentication. I fixed that but the "Array to String..." message persists. Anybody out there have a clue about this? Can anyone at least point me in a direction to find what's causing this? This has to do with the security module and sending a Password Reset email to a user who's forgotten his/her password.


            • #7
              Failed to authenticate on SMTP server with username .. is simply from an error from your smtp server. Your username and password login to the smtp is wrong.
              Try doing an smtp connect via telnet first to verify that everything works. And do remember that some servers need a HELO
              See for example:


              • #8
                Thank you, rr. I actually figured that out and fixed the issue yesterday after speaking with the hosting company of my VPS. The username and password were correct but the host was blocking outgoing mail from the "$sendfrom" address. I was sending from a sub-domain where the main domain was NOT being hosted on the VPS and was forwarding somewhere else. MX records didn't match for the main domain. I'm not sure why I sometimes got the "Fatal Error" message and sometimes the "Array to String..." message, but they were both being caused by the same thing. When I switched to new hosting/new VPS, the email settings were different and so the errors occurred.

                Your help is appreciated.