No announcement yet.

ScriptCase v8.0.015 (10-30-2014 19:06)

  • Filter
  • Time
  • Show
Clear All
new posts

  • ScriptCase v8.0.015 (10-30-2014 19:06)

    New functionalities

    - Added Timezone configuration in the general settings on Scriptcase.
    - Added Timezone configuration in the Scriptcase's production environment.
    - Added Timezone configuration in the ScriptCase installation.

    Specific correction

    - Fixed display issue of values ​​in DATETIME columns when there is a grid lookup.
    - Fixed issue in the char application when the searches results in records not found.
    - Fixed problem when using PROCEDURES on multiple records and editable grids Forms.
    - Fixed problem in macro sc_apl_conf when used on mobile devices.
    - Fixed problem in the alignment of the totalization when using dynamic Group By.
    - Fixed issue when generating a form with fields running position on the block, using the macro sc_field_display.
    - Fixed problem in back button to edit a record from a Grid of an express creation, accessed on mobile devices.
    - Fixed problem creating the log module using Firebird connection.


    - Fixed problem inserting images into BLOB fields in Oracle ODBC connection.
    - Fixed problem on the button to display the INSERT commands in the list of project applications.
    - Fixed problem executing SQL on forms with fields named with numbers.
    - Fixed the display issue on the custom messages in the SQL configuration from Chart applications.
    - Fixed issue in the footer toolbar, when the form has the block with the calendar fields.
    - Fixed issue from date and time fields set to null when using the Copy button.
    - Fixed issue when clicking the "New button" in the Grid application initiated by the filter, which has a link to a form inside an iframe.
    - Fixed problem with cursor buttons disabled in the Scriptcase themes.
    - Fixed issue in the HTML editor field to limit the amount of characters to display.
    - Fixed problem when using an intreger field (bigint) in terms of grid applications using advanced search.
    - Fixed problem deleting old versions of the project.
    - Fixed issue on the "warning to save" after leaving the settings from header, footer and summary without saving changes.
    - Fixed issue when returning values ​​in date fields in the search onScriptInit event.
    - Fixed problem displaying fields when the table is named with lower case in Firebird.
    Last edited by John L. Santos; 11-07-2014, 11:44 AM.
    Best Regards,
    John L. Santos

    Bug Tracker Team
    NetMake - IT Solutions

  • #2
    Hi John,

    I noticed that the time saved in my database tables is Recife's timezone. I just thought it would capture the local timezone/system date once I deployed it already to another production server. Having seen the timezone functionalities, I upgraded to the new version. However I always got the error below that has something to do with said function.
    "Fatal error: Call to undefined function set_php_timezone() in C:\Program Files (x86)\NetMake\v8\wwwroot\scriptcase8\app\myproject name\myapplication_name\index.php on line 450"

    Is there anything I need to do somewhere? I already adjust my timezone to Asia/Manlla under the "System Settings". I also tried to create a blank application without any date-type field, and the same error occurs.

    May I request to look into this ASAP, as I have deadline to meet. This is crucial since I have a lot of date/time-fields to deal with my system.
    Your immediate response will be highly appreciated. Many thanks!

    Last edited by MySJ; 10-31-2014, 04:47 AM.


    • #3
      MySJ, was it working with you ok before this latest update?


      • #4
        Hi Mike,

        Yeah, it's working fine before the update.


        • #5
          Hi Mike,

          Got a reply from Support. Will download the version again and feedback you on the result. Thanks much.



          • #6
            good, i was thinking this way, because the timezone thing was added to to cover the settings in the sc php version that is installed for the development, it will either not reflect your production, or you can control it anyway from php.ini inside the wwwroot of the sc, note that if everything else ok then turning the timzone sittings will take the default php.ini which is already defined in the mentioned patch of sc php version which comes with it, hence, it is reversible anyway if it was working before the latest update

            good luck


            • #7
              Hi Mike,

              Actually, I also modified the php.ini and set it to my timezone but still got an error. Anyway, just want to inform you that it's working now after a manual update.
              Maybe something went wrong during the course of my automatic update. Don't know... Good thing, all my newly created apps are ok now.



              • #8
                Good, congratulations, since 10 months or more, the automatic update never worked with me but once or twice, i always do manual update, it is better i think, sometimes you still need the previous version because of new/old bugs appears as a surprise loool so i keep them as zip for cautions

                thanks for the feedback,



                • #9
                  Hi, I'm having problem uploading images and documents to database since the upgrade (MySQL). The problem is on my production server but not during development. The two are using the same database so the problem must be related to PHP or server config.
                  The Prod. Server is hosted, file uploads and downloads worked before the upgrade but after upgrade I cannot upload or download documents or images. I've checked the tmp dir and the document gets uploaded there so it is something with saving to database...
                  Thank you


                  • #10
                    Same problem uploading as file (not to database)... I'm not happy.

                    Not shure if this is related but if I select an image or document in one session and not pressing save, the temp files is created in _lib/tmp as they should. If I then browse the same application in another session (on another computer) the tempfiles are deleted by the other session! This is not happening on my Dev server. So I think the temp file is deleted before it gets saved, only on the prod server. The prodserver is in another timezone.
                    Last edited by HakLin0816; 11-01-2014, 10:18 AM.


                    • #11
                      Sorry for my English.
                      After updating to version v8.0.015 , after each compile the application and uploading to the server displays the message "Fatal error: Call to undefined function set_php_timezone ()".
                      Before the update everything was ok .
                      Update accomplished automatically. Then I re- installed the earlier version and made ​​the update manually and again it was the same . At the end of the installed version of the .exe file that I downloaded from the website . The problem has not gone away .
                      I have a project that I have to give until 3.11 .
                      Please help , what to do.
                      Maybe there is somewhere available Installation file for versions older than the current version ?
                      Last edited by badger; 11-01-2014, 10:59 PM.


                      • #12
                        hi badger,
                        install latest version 8.15 manually
                        after that, if problem exist, go to your php.ini in of the newly updated SC package and check the time-zone settings
                        they made a link to it from SC setting itself, perhaps is a conflict, solve it
                        also, is this fatal error you are getting in the production or the development, before the deploy?


                        • #13
                          Thanks for the reply. The problem is only when I copy the compiled application on the client server. On the local machine everything works. I do not have access to php.ini on the server client.
                          But the problem temporarily solved. I found an older version of the installation file Scriptcase. Once installed, everything works.


                          • #14
                            - Fixed issue using the macros sc_connection_edit and sc_connection_new when used in the production environment.
                            Not fixed. sc_connection_edit work only in developement environment
                            Giorgio Bravi
                            Dolphin Software & Thinkware


                            • #15
                              Already reported:

                              Dave Prue
                              Code Whisperer
                              Lahar International Corp