Announcement

Collapse
No announcement yet.

Problem with sc_mail_send.....

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with sc_mail_send.....

    Hello, i have a problem with sc_mail_send, on Windows 7 + SC 8.1 + XAMP, works very well.

    In Apache server and PHP 5.6, the mail is sent only the first time for all APP, example:

    from the menu i call one Form or Blank that send one email, the email is sent successfully,
    if i call a second time the same form that i had called previously sc_mail_send runs and responds
    that the email was sent (does not generate errors), but the mail is not sent !!

    If i close the browser and delete the browser cache, came back to the website and sends e new email
    the email is sent.

    I can not understand where is the problem.

    Many thanks for your reply

  • #2
    Problem solved, the problem was created because in Apache server there is a SSL Certificate for payments.
    The sc_mail_send() function of SC8 after called the first time does not reset some internal variables SC8,
    this happens only in a website that have SSL certificate.
    I solved it by replacing sc_mail_send() with PHPMailer.

    To solve this problem I lost about two days of my work, I would only add this:

    Dear Netmake Scipt Case is a powerful development system, unfortunately i lost a lot of my time beacuse the documentation is very very poor, I also think that SC8 is not tested in all its conditions


    Comment


    • #3
      I also found another solution, excluding the App in SSL using redirects command in .htaccess.
      But this solution did not like my customer.

      Comment


      • #4
        I'm having an issue like this as well. sc_mail_send() sends an array or email addresses selected from the database as "BCC" when the site is http, but switching to https, they don't go. Get SwiftMailer Exception.

        Comment


        • #5
          SSL SMTP normally uses other ports, did you take that into account? It depends on your mail host.

          Comment


          • #6
            Dear all,

            I have the same problem, I test with TLS and SSL but macro sc_mail_send never work. I confirm that OpenSSL support is enabled, but is not possible to authenticate with gmail

            Error
            stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
            Error
            stream_socket_client(): Failed to enable crypto
            Error
            stream_socket_client(): unable to connect to ssl://smtp.gmail.com:465 (Unknown error)

            I'm agree with multisystems2 "Dear Netmake Scipt Case is a powerful development system, unfortunately i lost a lot of my time beacuse the documentation is very very poor, I also think that SC8 is not tested in all its conditions"

            Regards!

            AYMG

            PD: Using the same configuration, I can send emails from Python scripts in the same server.

            Comment


            • #7
              Is very curious, in devel environment (scriptcase) not work, but after deploy, work normally, I mean, send the email...

              Any idea?

              Regards.

              Comment


              • #8
                I get the same problem

                Originally posted by multisystems2 View Post
                Hello, i have a problem with sc_mail_send, on Windows 7 + SC 8.1 + XAMP, works very well.

                In Apache server and PHP 5.6, the mail is sent only the first time for all APP, example:

                from the menu i call one Form or Blank that send one email, the email is sent successfully,
                if i call a second time the same form that i had called previously sc_mail_send runs and responds
                that the email was sent (does not generate errors), but the mail is not sent !!

                If i close the browser and delete the browser cache, came back to the website and sends e new email
                the email is sent.

                I can not understand where is the problem.

                Many thanks for your reply

                Comment


                • #9
                  Can you share your phpmailer script sir
                  thx before

                  Originally posted by multisystems2 View Post
                  Problem solved, the problem was created because in Apache server there is a SSL Certificate for payments.
                  The sc_mail_send() function of SC8 after called the first time does not reset some internal variables SC8,
                  this happens only in a website that have SSL certificate.
                  I solved it by replacing sc_mail_send() with PHPMailer.

                  To solve this problem I lost about two days of my work, I would only add this:

                  Dear Netmake Scipt Case is a powerful development system, unfortunately i lost a lot of my time beacuse the documentation is very very poor, I also think that SC8 is not tested in all its conditions

                  Comment


                  • #10
                    Hello ,
                    I'm trying to send email and I got more or less the same error:
                    stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
                    Not being a serious programmer I'm wondering which is the problem and how to fix it.
                    Setting is really standard like following. I'm on development side on my pc and I'm trying to use
                    $mail_smtp_server = 'smtp.googlemail.com'; as testing


                    $mail_format = 'H'; // Message format: (T)ext or (H)tml
                    $mail_copies = ''; // List of the emails that will recieve the message
                    $mail_tp_copies = ''; // Type copies: BCC (Hiden copies) or CCC (Regular copies)
                    $mail_port = '465'; // Server port
                    $mail_tp_connection = 'S'; // Connection security (S) or (N)
                    $mail_attachments = $file_attach ;

                    Thanks

                    Comment

                    Working...
                    X