No announcement yet.

ScriptCase 8 - Bugs

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by penguinale1980 View Post
    The On Record Event on pdf application does not exist!!!!

    The image on the pdf dos not escale correctly
    I have the same problem.

    I've been waiting for netmake fix the error, but the image does not scale and does not fit the size of paper, leaving a margin on the right and down, unscrewing the texts.


    • grid detail in master / detail app - application link pencil unusual appearance


      I have a form that is a master / detail app in SC8 (unsure if this issue relates to SC7 as I haven't tried it). The detail part is a grid.

      Like many other posts have indicated on this forum, to allow me to edit each record in that detail grid I need to use an application link, which should add a pencil to each row of the grid.

      On adding the link, when running the app I get this:


      Notice that there are no such "pencil" icons appearing. However, I tried right clicking on the detail area background. This popped up the browser's context menu (Chrome in this case). From that menu I chose "Reload Frame" - note this is a browser reload frame request - nothing to do with SC per se - see pic below:


      It caused just that detail area to refresh - and lo and behold - the grid now shows the "pencils" (see pic below):


      They behave as they are supposed to. So why do they NOT appear on first load and need a refresh within the browser? This is of course no good and I trust this is a bug, and possibly related to many other issues reported on here regarding disappearing buttons etc? I also notice (between the last picture and the first 2), that the frame size originally created for the grid without pencils, is a bit too small once the pencils appear (but fine for the first 2 pics). This to me implies that SC is not aware of the need for pencils when it initially determines the frames size, which may also be related to why they don't appear initially too.

      Over to you NetMake...


      • There seems to be a few bugs with disabling fields on insert/update, i.e fields re-enabling under certain conditions when they should stay disabled. I will add others that i find to this post.

        - When the a Calendar field is set to be disabled in update or insert mode and the icon is visible. Using the Calendar date picker via the icon, The Calendar still allows the user to change date and save, even with the field disabled.

        - After Performing a quick search on a multiple record form and then clearing search to return all rows, will re-enable previously disabled fields.
        Last edited by mikelaw; 09-02-2014, 11:15 AM.


        • Some Strange things I Notice About Mobile Forms - SC8

          I noticed the following and would appreciate any fixes people have discovered:

          1) At the bottom of the mobile form, there is a message saying "Display web version" right in production. Is there a way to get rid of this?
          2) The menu comes out in a dark green background with menu items labels being black written on very dark grey menu items; in short totally illegible until clicked on. How is this fixed?
          3) For a detail form (using master-detail of form app), the system does not generate a mobile version. Perhaps because it is not single record. I there a way to have multiple record forms show up without needing scrolling in SC8? Dumb question maybe.

          SC8 version is 8.00.0006 (latest) and changing the menu type doesn't make a difference.



          • Text Autocomplete Broken (HUGE deal)

            Text autocomplete in 8.006 is toast. This has impacted our release, did not expect it to suddenly die and at this point have too many v8 forms to go back. Not sure how to get a previous mini-release.

            I can see the query go up and the values come back under the javascript debugger, so that much is definitely working. Fast too. List comes back in the debugger, can see all 10 values. But no popup. This form was working before my foolish update.

            Could not happen at a worse time. Please fix asap.


            • Scriptcase V8 Bug with Editable Grid View Form.

              When creating a where clause in a select combo box, the fields in older rows becomes blank in previously created records.

              I have not updated the older records but because of the where clause in the select lookup box removing selections from the lookup, it changes older fields to blank. This change isn't noticeable until the page is refreshed. e.g come back to the form later and all the fields are blank in that column.


              • Bug:

                - create a container application, two columns, column 2 2000 pixels heigth
                - in the large container create a tab application, containing a form with a lot of fields.
                - generate the application.

                : problem: the tabs in 8 do not occupy the full height as in SC7, but stop half-way. So inside of tab you get a scrollbar. There is no propertie to set the height of the tab.

                *very* ugly. I think that the tab should take-over the height of the form.

                If i change the tabtype from iframe to normal the compilation goes wrong with some mystic error about ' linking application is not a grid' UH?
                Last edited by aducom; 09-04-2014, 03:26 PM.
                Albert Drent
                aducom software netherlands
                scriptcase partner, reseller, support and (turn-key) development


                • Numeric Field names: Update not work

                  i have a table with tinyint(1) fields (Yes/No Checkboxes) where the field names are numbers like 2014, 2013, 2012.

                  In this case, Scriptcase 8.00.0007 generates invalid SQL Statements (.....2014 = 0, 2013 = 0, 2012 = 0, 2011 = 0,....)

                  This is not allowed. It schould be (`2014`=0, ...).

                  Thank's for fix.


                  • Its stucked! Navigation in records taking very long time in 8.00.0007 what was in initial release . Please fix the older bugs first the add additional features. You're killing our valueable times. I'm fearing about sc updates since back to v8 released. You're fixing a new bug then older bugs clomes again? How long this will continue?
                    S. M. Rajibul Huda
                    CEO & Founder


                    • Right Place to report bugs?

                      Originally posted by stephanw View Post
                      i have a table with tinyint(1) fields (Yes/No Checkboxes) where the field names are numbers like 2014, 2013, 2012.

                      In this case, Scriptcase 8.00.0007 generates invalid SQL Statements (.....2014 = 0, 2013 = 0, 2012 = 0, 2011 = 0,....)

                      This is not allowed. It schould be (`2014`=0, ...).

                      Thank's for fix.
                      Hi again
                      is this the right place to report that or is there a ticketing system to report bugs?
                      For me, this bug is critical... when not fixed, i think i have to check, if the db provider can change the field names. That could be dificult, because i'm one of several people who using this db. Please reply, what to do. Thank you!

                      Best regards


                      • Originally posted by keyji View Post
                        Hi everyone,

                        I m facing a critical problem since yesterday when i ugraded to scriptcase v8.002. Field link from grid_t1 to form_t2 is not working.
                        Everything was perfect last week.

                        Please do you have any idea.

                        Here is the error:
                        You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 View SQLSELECT count(*) from tier where fk_idappdossierflux=3 and (idtier = ) Close

                        Same problem linking grid to form application and trying to add a new record.


                        • Originally posted by fcarmonah View Post
                          Same problem linking grid to form application and trying to add a new record.
                          1- we are now in version 007, try to upgrade
                          2- if you have the id field not included in the form fields (you hided it or excluded it from the fields list) try to add it visible and see if changes
                          3- check the error and see where this code leads to


                          • Hi,

                            Please open a thread to address to any new new bugs.

                            Every bug posted here will be reviewed. Feel free to open a new topic regarding any issue that was already posted here to have a closer follow up.

                            Bernhard Bernsmann