No announcement yet.

ScriptCase 8 - Bugs

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The On Record Event on pdf application does not exist!!!!

    The image on the pdf dos not escale correctly


    • #17
      V8 - Project not importing

      I upgraded from 7.1 to 8 this morning. I have imported all my projects fine except one, which is the one we develop on the most. It's also the largest project of the bunch. When I import the file for that project, it appears to run fine, prompting for the new project name (which like the others I imported successfully, I don't change) and then it stops as though it's finished. But when I go to look at my projects, I see them all but this one. After trying the import again, I noticed this text below the summary window (see attached). What could I be doing wrong in this case to make it fail? Or what should I change to get it to import correctly?

      I'm running V7.1 and 8 as separate apps on my Windows 7 machine.

      Thanks very much,



      Edit: Well that image attached is pretty much useless. Here's another link to it:

      Edit 2: Stranger is what I notice when I start studying the picture. The grid_Passwords app, referenced in the pic - I wondered if that particular app in my project was causing the issue. So I unzipped the backup, removed that particular app, and zipped it back up. Then ran the import, and it imported with out error.... There must be something in that particular app that was causing a problem. Recreating one app wouldn't be too big a deal for me if that's all it was. If I still have issues on this particular ticket, I'll post them here.

      Final Edit: Scriptcase 7.1 didn't mind an extra comma in the grid's sql code... I copy / pasted the sql into another app, and it failed. Upon further inspection, my last column I was pulling in the code had a comma after it. I looked again at 7.1 and sure enough - there was a comma in it and it seemed to work fine. So I took the comma out and voila - all works fine. Feel free to delete this - sorry. Posting the issue did help me step through it all though LOL
      Last edited by mslatter; 07-29-2014, 04:30 PM.


      • #18
        Originally posted by penguinale1980 View Post
        The On Record Event on pdf application does not exist!!!!
        Funny thing with that, if you use a project-search to find something, which is inside the on_record-event, it is found, but not shown in the event list.
        The on-record-event is existing, tested it with an converted project. It is just not shown, something like a missing flag for that event to show in an pdf-report.




        • #19
          Dynamic summary/groupby does not word if the grid is integrated in container, tree menu or menu. I also tried your sample apps, got the same result like my app. Please check and fix.


          • #20
            Glad it worked but .....

            Why did'nt you used the conversion recommended method?
            Professional Scriptcase Services
            Support/Outsourcing/Mentoring for projects migration to Cuba-Platform


            • #21
              Hi Bernhard, the bug with MsAccess ODBC connection persist, Sc8 can´t list the views in the datasource list when I try to créate a grid application.

              only list the tables, (since sc6.31 up to date).

              please fix this bug because I continue using sc6.020 due to this bug, I never use the Sc7 and never will use Sc8 while this bug do not fixed.



              • #22

                I am having a problem uploading a 38MB file to my scriptcase application using mysql as the backend database.
                sc8 upload.jpg

                The file uploads and the progress shows 100% but the upload pending is still set and I cannot save the record. Any ideas on how to correct? Smaller files seem to work fine.

                I have seemed to fix the upload issue (max_upload_size in php), but when you go to add the record to the database I get an error with an X and no message. I fixed this error condition by updating the my.cnf file with a change to the MAX_ALLOWED_PACKET = 500M entry.

                These two setting changes fixed this error in v7 and v8.

                Last edited by rjkantor; 07-31-2014, 10:18 PM.


                • #23
                  Hello Bernhard,

                  I'm currently developing on SC v8 and today I've been dealing with a problem that I'm not sure it's just a version 8's problem.
                  I wrote an app to upload a file (single file) and rename it using an onBeforeInsert event that is working perfectly, however I just noticed that even though in MySQL, the new name is saved correctly, the actual file is uploaded with the old name.
                  As this is my first time developing such a script in Scriptcase I don't know if this is a normal behaviour in SC or I'm missing something here.
                  Should I write another script in an onAfterInsert event to rename the file again? (which would be really odd)
                  Any thoughts about it?


                  Best regards,
                  Ivan Saavedra Maufras
                  Last edited by isavma; 07-30-2014, 06:54 PM.


                  • #24
                    I converted to sc8 my app but on android mobile the button on login control form is not visible. I changed also with the new botton style but no change. Any help about it ?


                    • #25
                      Hello Bernard,

                      I have just converted one of my applications from V7.1 to V.8.
                      In a grid application, clicking the detail will show nothing. It's working on V7.
                      I have changed some settings like show in another page / show in another window etc. The result is the same.

                      And calendar application is also too poor to use in a professional environment. I couldn't see any color setting changing via event type. Any event type definition etc. Really frustrating ! This is a very very basic event field in all calendar app. Agenda view is also too poor! It can be in a daily grouping view in the order by time.


                      • #26
                        CHECKBOX Problem

                        Hi Bernhard
                        i imported my sc7.1 Apps to sc8. i have several checkboxes, some with lookups in DB Tables, some with manual lookup (Label=empty, Value=1). In SC7.1 works good. Now in SC8, the checkboxes with manual lookup not work AFTER navigate to a new record. Then the checkboxes disapear, only the Label shows. In the first record shows, everything ok. Also the checkboxes with DB Lookups works fine. Navigating back to the first record not helps... then also first record shows broken checkboxes.

                        I attach to screens which shows you the problem.

                        Thank's for your help... i need this form :-)

                        Best regards


                        • #27
                          BUG in TO DO LIST:

                          if you forget to assign a responsible person for a task, then you will not be able to maintain it at all.

                          so be sure to enter a responsible person.

                          ************************************************** ********
                          We are Developing your Future Business Requirement right now with Scriptcase.


                          • #28
                            When updating an existing record on a form any manual set select fields loose their options after updating the record. When you navigate away from the record and come back the select options show up in the drop-down again, but if you hit "update" on the record they turn into drop-downs with 0 items available to select from.


                            • #29
                              Hello guys,

                              Just to let you know, we are currently reviewing and working on issues posted here.



                              • #30
                                When I run my application from my development environment I am seeing the following error (see below) on the home page of the sample document library. I am not using database sessions and I am using mysql connection so not sure why this sqlite error is occuring. When I deploy to my production site, I don't see the messages. Please advise. This ran fine in the SC7.1 evironment.

                                Strict Standards: Declaration of ADODB_pdo_sqlite::_connect() should be compatible with ADODB_pdo::_connect($argDSN, $argUsername, $argPassword, $argDatabasename, $persist = false, $charset = '') in /opt/NetMake/v8/wwwroot/scriptcase/prod/third/adodb/drivers/ on line 305