No announcement yet.

ScriptCase 8 - Bugs

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Error when saving changes to my form_tb_documents from document management. The form is not holding the single record setting. When changed and saved, error occurs.

    Undefined offset: 6 | Script: /opt/NetMake/v8/wwwroot/scriptcase/devel/class/page/nmPageFld.class.php linha: 12346

    Id do menu nao encontrado.
    file: /opt/NetMake/v8/wwwroot/scriptcase/devel/lib/php/
    function: StartIncItensCoolJsMenu
    line: 2728
    topico -> [sub_form]
    Last edited by rjkantor; 07-31-2014, 11:19 PM.


    • #32
      Here is a screen shot of the connection error I get (posted in another thread.)connection-issue.jpg


      • #33
        Error generating source...

        Undefined offset: 0 | Script: /opt/NetMake/v8/wwwroot/scriptcase/devel/class/generator/nmDados.class.php linha: 2862


        • #34
          PDF with AliasNbPages do not work

          After convert the sc7.1 to sc8 application, i have a lot of errors, some of them have been writen in other post.

          I have some that are not posted before:

          1) The pdf report is wrong in locations
          2) The margins are not working
          3) The AliasNbPages don't work and generate a Fatal error: Call to undefined method TCPDF::AliasNbPages()
          4) The dynamic filter and search don't work for checkbox, radio, select, etc fields

          I'm waiting for a patch ASAP that correct this bugs and all i have read in the posts.

          Thank you very much.


          • #35
            SC8 Import MS SQL

            Creating New Project select existing template i.e. shop or helpdesk, select D/B MS SQL connecting , create a new db i.e. test no problem (SQL account is sa) save.

            step 1/4 creating the new project Ticked
            step 2/4 preparing the database and the application to import Ticked
            step 3/4 importing the application Ticked
            step 4/4 Creating the database Constantly process never finishes

            Tried MSSQL Server Native SRV and PDO same issue. BUT SQLlite PDO works OK !

            If I manually create a blank project create database, tables and views NO Problem with MSSQL.

            Has anyone else tried the templates with MS SQL ?
            Attached Files


            • #36
              Dynamic menu not showing in Android (old bug).
              S. M. Rajibul Huda
              CEO & Founder


              • #37
                Just a compliment. This To-Do list is very cool. I really needed it.
                Rod - Developer


                • #38
                  I am trying to upload an *.ico file to images.

                  First does Scriptcase 8 support *.ico files

                  Second when trying to upload the error is "File exceeds the maximum size allowed of 5MB." the file size is actually 2kb.



                  • #39
                    Single valued manual checkboxes gone after navigating through records. Very annoying. Please fix it as early as possible.
                    S. M. Rajibul Huda
                    CEO & Founder


                    • #40
                      In a grid Form, if you have a checkbox field or radio field or select field and you have them set to manual, the field disappears after an insert or update. Refreshing the form brings them back.
                      Rod - Developer


                      • #41
                        Error navigation buttons on a link with a unique form grid

                        In a grid when I make a application with a single link type fomulario not I select to enable navigation buttons on target application, but I still displaying the navigation buttons to enter the single form.

                        This problem occurs in a grid of a new project and a project migrated version.
                        It is a problem of ScriptCase? or is there some parameter that must be considered.

                        ScriptCase v8 installed it on the same computer and other equipment to confirm the above.

                        Please resover your support for this problem.


                        • #42
                          Detail View in Scriptcase v8

                          I get the following persisting error message when I try to click on detail view of the grid.

                          Parse error: syntax error, unexpected ',' in C:\Program Files (x86)\NetMake\v8\wwwroot\scriptcase\app\HAdotCO\gr id_hostint\grid_hostint_det.class.php on line 853

                          832| $SC_Label = (isset($this->New_label['hobbies_activities'])) ? $this->New_label['hobbies_activities'] : "Hobbies Activities";
                          833| $conteudo = trim($this->hobbies_activities);
                          834| if ($conteudo === "")
                          835| {
                          836| $conteudo = " " ;
                          837| }
                          838| else
                          839| {
                          840| $conteudo = nl2br($conteudo) ;
                          841| $temp = explode("<br />", $conteudo);
                          842| if (empty($temp[1]))
                          843| {
                          844| $temp = explode("<br>", $conteudo);
                          845| }
                          846| $conteudo = "" ;
                          847| $ind_x = 0 ;
                          848| while (!empty($temp[$ind_x]))
                          849| {
                          850| if (strlen($temp[$ind_x]) > 30)
                          851| {
                          852| $conteudo .= wordwrap($temp[$ind_x], 30, "<br>") . "<br>", true;
                          853| }
                          854| else
                          855| {
                          856| $conteudo .= $temp[$ind_x] . "<br>" ;
                          857| }
                          858| $ind_x++;
                          859| }
                          860| }

                          I think it has to do with error comma after "<br>",
                          Instead it should be a dot instead of comma to concatenate, like this "<br>" . true;
                          I cannot change it inside script case to try it.

                          Any ideas if any one get the same error when viewing detail view from any grid? and how can I fix this.

                          Note: project was mirgated from sc 7.1 to sc 8

                          Let me know


                          • #43
                            Error with detail in SC8
                            Creating a grid application in SC8 with detail option activated.
                            Build the app with nothing modify. When clicking on the detail option stops with this error
                            Parse error: syntax error, unexpected ',' in C:\Program Files (x86)\NetMake\v71\wwwroot\scriptcase8\app\Soudex\g rid_dossier\grid_dossier_det.class.php on line 965

                            doing exactly the same in SC7 and no problems, all works like a charm.

                            Is this a known bug from SC8 ?


                            Sylvain Danigo


                            • #44
                              i have converted sc7 project to sc8. my project is working fine on pc but on android browser i am getting an error of 'unauthorised user' for form and control application. whereas grid and other apps are working fine. it would be really greatful if someone can give the solution on this. earlier once i had similar kind of problem when the app was installed on sub domain. but this time its loaded on direct domain. web is ok.. but mobile is problem. thnx in advance.


                              • #45
                                Dynamic menu not showing in Mobile