No announcement yet.

Source code generation problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • Source code generation problems

    Everytime I want to generate a project source code, there is always an application that does not allow to finish generation process. It keeps waiting an unlimited time, so I have to cancel, and when I do so, a pop-up error window appears (see attached image). error_sc.png If I click the link, this error is showed:

    Invalid argument supplied for foreach() | Script: /var/www/html/scriptcase8/devel/class/generator/nmFontePHPForm.class.php linha: 12764
    All the applications are generated, except the one that blocks the process. I thought that the problem was related to a specific application, but I realized this happens with different apps.

    Also, I noticed that during generation process, a folder with a weird name is created inside the app folder of my scriptcase installation (see attached image). error_sc2.png

    To generate my project source code properly, I have to close scriptcase session and open my project again. It works fine for a while, but later this problem comes again.

  • #2
    I noticed this immediately after doing an update a few days ago. I solved it by uninstalling scriptcase 8 and re-installing. The request to update still comes up but I am now ignoring it, but the error doesn't come up any more. I hope that helps.


    • #3
      You're right automan; the problem came with the last update. I almost reinstall scriptcase, but despite the fact that there were not any messages when opening Scriptcase, I checked for updates just in case and some of them were available. So, I updated scriptcase and the problem was solved.