No announcement yet.

New Error after Update when running Login form

  • Filter
  • Time
  • Show
Clear All
new posts

  • New Error after Update when running Login form

    Good afternoon,

    I have been running 8.1 with PHP 5.6 for a few weeks just fine. Did the latest update today (8.1.007) and when I try to run my local version and log into my Sec_Login form, it takes my credentials and after pressing the Login button I get:

    Fatal error: Call to undefined function sc_convert_encoding() in C:\Program Files (x86)\NetMake\v81\wwwroot\scriptcase\app\ET\_lib\l ib\php\nm_gp_config_btn.php on line 76

    Any ideas? I do have a backup so am not too concerned, but didn't want to roll back if it was an easy fix. Seems my version of Scriptcase doesn't know what sc_convert_encoding is....

    Thanks very much!

    Last edited by mslatter; 09-10-2015, 04:12 PM.

  • #2

    We've also recently updated and we're getting the same error.

    Same exact php file and line number.

    Edit: Renaming the apps folder and regenerating my apps appears to have fixed everything. Thanks!
    Last edited by wizcpom; 09-11-2015, 03:48 PM.


    • #3
      Ok for those that come looking, here's what fixed it for me thanks to Carlos Ferreira at Scriptcase:

      Delete all the content in the "app" folder which is located in the scriptcase program folder. (** I made a copy of it first before deleting just in case)
      For me, that directory on my Win 10 machine is located here: C:\Program Files (x86) \ NetMake \ v81 \ wwwroot \ scriptcase \ app

      After that, regenerate the source code for the project.

      Worked for me! Back on track...thanks again Carlos!



      • #4

        The fix is generate the source code of the project.

        Sorry about this issue.
        Best regards,
        Carlos Lacerda.
        ScriptCase Commercial Manager.

        Skype: carlos.lacerda82
        Visit our Blog:
        Visit out fan page:


        • #5
          Thanks for your posting this information. I was having some flaky things going on with my SC that had never happened before today's update. I followed the same procedure as was given you (including the backup) and all seems to be back to normal.
          Again, thanks,