No announcement yet.

Deployment Issue on Centos

  • Filter
  • Time
  • Show
Clear All
new posts

  • Deployment Issue on Centos

    it's passed some time since I deployed last app, but now, when trying to deploy a new project (sc 8.1) to a linux box (apache, php 5.6.18, mysql on another server), I cannot create the correct DB connection.
    Also tried to chmod -R 777, can enter the profile configuration and list the tables, but nothing get saved, and once I get back, it returns me to config page..

    As a side thinking, I don't understand why deploying with scriptcase is not yet "friendly", despite the overall quality of the system....

    Thanks for helping
    Last edited by lrweb; 02-08-2016, 06:26 PM.

  • #2
    Usually it is easy, but all kinda of settings on a machine can screw this up. So I suggest you logon yo your linux box and in a shell connect with the remote mysql. First check if that works.
    If that doesnt work try it as super user.


    • #3
      As I said, it works. I can connect to the remote mysql, and I can do it also via the prod configurator of the deployed project.
      The issue is that connection settings are not saved when I logout from configuration.


      • #4
        It surely is a security issue. Anyway, solved deploying the whole project to my local machine (windows 7 with WAMP), creating the connection as it should be in the production server, and moved everything. This way I also didn't have to chmod production folder temporarily...


        • #5
          Getting back to this: my solution worked only partially. in fact, it left me with the impossibility to generate any report in production, due to the fact that scriptcase cannot write in tmp dir...
          Went investigating, this could be related to apache running with PrivateTmp (it is a Centos box) and hence tmp folder is not _lib/tmp....
          Tried to disable it and no luck.

          Anybody out there having success with Centos or REdHat?
          Last edited by lrweb; 03-05-2016, 06:49 PM.