New PDF exports not working

I have some grids with pdf export setup as one of the options. The export works perfectly in the development environment, but when deployed to the server, I get the rather unhelpful message:

Error creating PDF file, contact technical support.

This clearly is poor error reporting ( it might as well just say ‘Tilt’), but I could get away with that if there were some indicators in the manual about what to do as a developer when you see this.

It’s obviously something to do with the server missing some library or other code that is in the dev environment, but I can’t find any indicator of what that might be.

Has anyone solved this?

PS… this is a standard grid… I’m NOT using the pdf generator
There are no indicators in the server error logs

Well… that didn’t take as long as I feared.

Couldn’t find any differences in the prod files, then I remembered that in an v8, there was a problem with permissions in the pdf library directories.

Sure enough, when I checked the server permissions, they were different to those in the dev environment.


I set the permissions to all files at 777 and the problem disappeared.

I’m not sure this is the full answer, as I think the directories should be 777 with the files as 644 or similar, but I don’t have time at the moment to dig deeper.


Netmake… PLEASE fix this at source. This sort of error should not need to be manually fixed after every version/ prod deploy.


I have had the same problem but it is solved now.
Following a part of my conversion with the SC support

I used the Ubuntu 18 version and there the library libpng12 is not available any more

… libpng12 is no longer available in the Ubuntu repository archives and as a result, some applications that
were not built with the newer libpng (libpng16) library fail to install. This issue is not new, since Ubuntu
dropped libpng12 with version 16.10, but those whom are upgrading from Ubuntu 16.04 to 18.04 LTS …

My steps

and now it works fine.

see also --> PDF Export klappt nicht

See also my recent posting:

This is back in version 9.10.022 (10)
It works fine in development environment, but not on the server.
I’ve updated the prod environment to the latest version AND changed the folder permissions (old problem) and checked the PHP.ini (old problem)… it still fails with the stupid non-specific error.

I’ve given up on this and am now removing it from all my menus.

My clients think we are incompetent… I’m damn sure we have less regard for the Scriptcase developers in this space. Its unnecessary and if you are going to use an external library, then you ned to make sure it works out of the box… not after hours of fiddling.

For the record, there is a more detailed discussion here.

BUT the problem is NOT solved.

Ife also provided more information here: