[SOLVED] Problems with Group by in Grid module

When I select the fields to group for, and then look in the Fields option, the Fields doesn’t store the correct label, even if I change it manually, later it overwrite with the label of the first selected field.

Log Error:
an error occurred while accessing the database. no such column: ext_sizes | Script: C:\Program Files\NetMake\v9\wwwroot\scriptcase\devel\class\interface\nmField.class.php linha: 2927

In Summary:

Each time you change fields (move, update or delete) in the Settings options both in Static and Dynamic groups, all the fields there gets overwritten by the contents of the first field in the list.


I have the same problem in the last 2 Weeks,

I have the same problem in version 9.5. Scriptcase when to fix it? It’s very bad.


Same here, but i can’t modify any field on groups or app crash…

Take a look at: Lot of bugs in GRID (9.5)

When the label changes, every new code generation made app crash because of malfunction in the code generator for lookups.

i noticed that when i lower the records amount to say 10 everything works. it’s not the sollution, but…

Any answer from Scriptcase crew? It’s a big failure, Scriptcase is useless in my enviroment right now.


The problem was solved in the 9.6.000 version.

Please, update and check if the problem has been fixed (fix available for new applications only).