403 errors when everything is 777

I tried a deployment of an SC9 project both on my localhost and a shared host (LAMP).

The deployment directories are confirmed to run PHP 7

info.php runs fine in the deployment environments.

After the project file extraction all directory and file permission show 777 (eek).

Attempting to access the deployed project folder reports a 403 error.

Anyone know of likely causes?

UPDATE- manually setting directory permissions to 755 and files to 644 improved matters

Note to SC Team; why does the deployment extraction come up with 777 permissions on everything?

Question to others, why 403 errors when everything is 777?

Just some ‘wild’ guesses. Did you upload using Scriptcase or a separate uploader? On localhost, I assume you have deployed locally? It highly depends on what you did. In general, if you ‘just deploy’ then the provider will set default rights to files. That could be 644, but I’ve seen 777. Another issue might be the ownership of files. I’ve seen ‘apache’, but also the user itself. So it’s depending on the provider. For local installs I can imagine that 777 is used as that’s for testing purposes. I use Wamp for my development tests (which is by default set for testing purposes), but on production I run Uniform which is setup for production out of the box. I cannot be sure that there’s some wrong on the SC side (loads of issues as you are well aware of) but I doubt if this is a scriptcase issue. More a hosting issue.

From my experience user/permissions are set always to 644 and 755 under Linux enviroments, and owner is the user connected. I always deploy outside SC, not sure if SC does something with permission and users, but I don’t think so.

Most of the time you are right, but I have seen ‘apache’ coming up as the owner. Depends on the way the webserver / apache is installed.

Maybe. Anyway, I’m aware of the trap now.


I wish I could be of more help. It’s a puzzle when things don’t work. The most trouble I had installing apps was on my Australian customers. For some reason your hosters do things differently. But if that’s the reason here I really don’t know.

Don’t know if you saw my related post and Giu’s replies, but the issue is the archive packaging on Windows. Unfortunately everything comes out 777 (directories) and 666 (files) on Linux. And on shared hosts there is usually no shell to quickly correct permissions. And the file managers found in control panels don’t include functions to recursively set permissions.

If deploying to a Linux OS host the option is either to directly FTP the deployment files or:if you need a packed archived to overcome the poor internet upload speeds we suffer from here

  • Move the deployment files to local linux machine
  • Check the permissions; I found they are usually correct at 755 for directories and 644 for files
  • create the packed archive on the linux machine
  • Upload
At this point all seems well.


I saw your post and it’s great that you managed to solve the issue.


This is my first time of using Scriptcase and I had wanted to deploy to my host. My host is uses Linux server. For my deployment, I decided to use FTP. However, my question is where to deploy the application. For example, my home directory on my host is /home/<myusername>/. There there is a subfolder called public_html. I am just wondering if the FTP folder specified in my Deployment screen should be ./home/<myusername>/ or /home/<myusername>/public_html?

Isaiah A.

Usually on shared hosts, If you are using your admin account for FTP access you will already be in /home/<username>

Maybe get Filezilla or WinSCP and explore the directory structure so you can see how it hangs together?

Anyway, let’s say your project is to go into /home/<user>/public_html/myproject , on the main (admin) ftp account I’d expect the upload folder in SC to be /public_html/myproject