"add new" button to grid

I’m using SC 8.1.008
I’ve added a Link to a GRID (not an editable form) and this puts the “pencil” icon next to each record and allows me to update that record by calling the form.
Easy enough. But I haven’t had any luck getting an “add new” or “insert” button that calls the same form and allows me to add a new record.
With an editable grid, the “add new” button is automatically created, but I lose the “columns” button that my users really want.
Am I missing something that will add the “add new” button to a grid?

Create simple a new button, typ link … and link to your form.

Master/detail in SC is designed to use,with 2 forma. As you say, grid loose the toolbar when used as detail.

As RHS mention, I use a button in master form to call the detail creation of new records.
Is,not what we want, and I started to work on a lib to insert toolbar on detail grids, but,don’t have time to invest on this,right now.

Master/Detail without using an editable grid is really not working for me an seems as bug to me. Not only the New button does not show up but also a configured application link to the detail form is not shown. I do not use editable grids (due to a specific reason). Unfortunately due to these limitations (bugs?) I cannot use Master/Detail forms in my application. Scriptcase can you please solve this urgently?

This is a long time issue. I will give you a surprise to smile. Click on your detail app and reload the iframe.

Thanks. Yes, I realized I could add a button calling the form, but ran into some problems.
For one, the “Save” button disappears from the form that comes up when I click the Add New button that I created.

Hello, were you able to figure out a solution for this issue???, I have the exact same problem; GRID is not showing “NEW” button and even if you link to the FORM and you try to update any record you dont get the “UPDATE” button.

I have found that I only get this problem when I run the GRID app from a MENU app, but if I run the GRID app directly I dont have this issue and the NEW and UPDATE buttons are available.

Any help will be highly appreciated. Regards,

This is an on going problem with buttons missing. I have reported this problem about 2 years ago first time and after last update I was hoping this is somehow resolved. I discovered that this was happening to me only when I copied one GRID App into another then did not regenerate the code (for the newly copied App). After discovering this I changed the behavior and any MOVE or COPY operation I immediately generated Apps. This solved the issue for some time but recently it came back. I’m also missing ADD NEW button. I think that the whole concept of creating INSERT/UPDATE/DELETE buttons is screwed up in SC and needs to be completely redesigned. Not saying that we have almost no control on single buttons created by SC.
Yes we can create custom buttons etc but then we missing certain features and everything has to be hand coded which is non-sense.
So far the only solution that I know of was re-creating the same App from scratch. I will be happy if somebody has some workaround. The GIU suggestion does not seem to be a solution as this is simply some kind of really hard to figure out bug and this issue is known for more than 2 years.

Here is what I did today. It makes things even worse.

  1. I removed old grid with the missing NEW button
  2. I kept the form (it is quite complex with child records etc) so I cannot spent entire day to recreate a form
  3. I generated single grid App as a parent to the form. When run it showed all records properly (but because there was no edit form linked it did not show NW button.
  4. I added new link and the FORM App. On the form App I double checked to select SHOW NEW BUTTON on the grid
  5. Generated, run - NO NEW BUTTON (so no way to add record)
  6. Opened Toolbar for the grid and added “Form Buttons” manually.
  7. Generated, run - STILL NO NEW BUTTON

I have to say I’m totally frustrated :frowning:

Personally I would like to be able to add/remove each button on every single App manually and have full control on the code BEFORE/AFTER it is clicked/hovered etc.


I have same problema, the form is in a iframe and the button for submit is ok, but suddenly disappears in time. The only solution for the user is to delete the cookies. And for technical support of Scriptcase, this is the only answer, clear the cookies. Very Sadly answer. Now I searching for another Rad. Striptcase is not responsive and have a lot of problems integrating with some cms. I integrate it, but my customer is really angry for not responsive features and randomly problems like this.

Has anyone solved this? Neither this thread or the one at http://www.scriptcase.net/forum/foru…button-to-grid are helping me.

I have deleted application and folders, cookies, recreated & generated application, to no avail.

Essentially, if the recordset is empty, the user has no intuitive means to create a new record. As “aka” says, it’s frustrating.

(I’m on SC8.1.017)

For what it’s worth, the issue was down to a field name SC didn’t like. I’ve had similar problems before; the code generator has a hissy fit and garbles the code because it can’t handle the field name. In this specific case I was working with a legacy mysql database where one field was named as group-name

Maybe this will help save someone’s sanity in the future.


H everyone,
I just wanted to leave a little note, since I encountered this again myself…and I eventually figured out the issue. Hopefully this might help someone in the future (possibly myself LOL).

There are multiple ways the form buttons (like insert, update, delete) can be controlled. With multiple ways, it is pretty easy, even for a SC veteran like me, to get twisted around a bit.

  1. Check the Security setting on the left menu of the app, and then make sure it was synched . Then check the group / applications option in the system menu when you log in as admin. You might have unchecked the access, update or other option for a specific app. This is how a certain set of permission is passed to each app when you use group level security.
  2. Back in the SC IDE, in a specific app, make sure that you actually have the form buttons option in the toolbar over the right hand side. If it is in the left, then it is effectively impossible to see it, regardless of permissions.
  3. In your onload event, make sure you didn’t turn a button ‘off’ for your user (group level).
    sc_btn_display(‘new’, ‘off’); // add a new record
    sc_btn_display(‘delete’, ‘off’); // delete a record (NOT ALLOWED)
    sc_btn_display(‘update’, ‘off’); // save a change
    If you have update off , then it won;t show up regardless of the permissions. This gives you run time control.
  4. Another trickier place to check is the LINK that is being used to open a form up from a grid. Or a grid from a grid, etc.
    In the grid app , make sure you have all the buttons you want checked, including the new button:
    Display button (new row) on the grid toolbar Yes
    and below that…
    Enable insert button on target application Yes

If you don’t have that set correctly , then the form won;t have certain buttons, and the grid might be missing the New button.

Number 4 above is usually not an issue if you create a batch of grid and form app at same time. The problem is when you might link to the same form from multiple grids. make sure # 4 is correctly set when you make the new link to the existing form.

Again, writing this for any SC user in the future who has run aground and needs a lifeline. It can drive you crazy, but stick with it. You can systematically test all 4 things above and 99% of the time it is some interaction causing unexpected results.
Good luck,

This helped me so much today!! Thank you! Thank you! Thank you!