app_retrieve_pswd error: 'ARRAY TO STRING CONVERSION' SC Version 7 01 0016

app_retrieve_pswd error: ‘ARRAY TO STRING CONVERSION’ SC Version 7 01 0016

  1. Verified creating a new application and empty MySQL database with only security modules generated by SC and all users in application.
  2. Verified with other old updated applications.
  • Procedure:
    Application execution
  1. Access to ‘change password’
  2. User in login box
  3. Ok button

Array to string conversion

After operation, user password has been changed and no notification has been generated. User password becomes unknown. User can’t log.
RESULT: all users in new or updated applications using app_retriev_pswd are locked by password update operation and there is no way to generate password or to access to application.

See attached file



Issue reported to our bugs team.

Bernhard Bernsmann

SC updated to last version. Version 7.01.0018
Bug still detected.

Hello Mr. Alcantara,

I just need to know what kind of security module you are creating and if you are changing any of the default information.

Groups based security model without changes on defaults generated by SC->Modules->Security option and previous created log (SC defaults used).

Tested in SC Version 7.01.0018

a) updated projects
b) a new empty project and new database with only security modules.

Hello Mr. Alcantara,

Thanks for your feedback.

Bernhard Bernsmann

SC Version 7.01.0019 -> BUG SOLVED.

Retrieve Password App SC - “ERROR: Array to String Conversion Array”

I’m having this issue using SC (and was having the issue with earlier versions of SC 8) BUT, at one point with SC 8 it DID work, without the error message. At some point, and I don’t know when exactly, it started giving the error message.

I’ve recently moved the site where this issue exists to a new server, but I don’t know if there was an issue before the move or not. I’m going to try to find out. In the meantime, this was supposedly fixed at some point in SC 7 but I’m having the problem in SC 8. The error message even happens in the SC development environment when I RUN the application.

Does anybody have a clue as to what is going on here?

I had the same issue in SC 9. And I had it working at one point with the same project before as well.

I managed to compare the source before and after. The only difference is my SMTP details. No change in the codes.
Turns out there was an error with the email account that I used. When I try to send out email using normal email client, the error message looks like this

Probably some character in the error message caused the error message variable turned into an array and unhandled by the scriptcase code.

2017-05-18 19_59_49.png