Due to some license issues I had to reinstall and re-register SC. Now I have problem with importing projects again. This has been reported numerous times. Last time I had this problem about 2 months ago I had to send last file to NetMake and they did something to it then sent if back to me. After this operation I was able to import. Obviously there is some bug in SC preventing from doing imports (in specific conditions) and this bug has to be fixed ASAP. It is crucial to be able to reinstall SC and re-import projects. I know I’m not the only one reporting this issue. The fact that it is not working as expected makes SC almost useless. I’m totally frustrated about this, because the issue is on going since over a year. Here is a message (which is misspelled) I get while importing

“The file was noy created by Scriptcase version 8”

I have about 30+ backup files of the same project, none of them can be imported back !


PS> did I mention CHECK SPELLING ?

Here is a fragment of the post from [SIZE=20px]MAY/2015[/SIZE]. Backup/Restore has not been fixed until now. This is one of the reasons I would not recommend SCRIPTCASE to other developers until the NetMake paradigm changes. Bugs remain unfixed for months (if not years).[/B]



Hello Arthur,
As I said back in may, we remade the backup / restore routine, it was one of the many features on the release of SC 8.1.

At that time you send your backup file to our support and the problem was solved. Your backup was fully functional after support worked on your files.
So, you went through this problem before, and you know how to proceed, contact our support and we’ll help you.

Furthermore, as Giu mentioned to you in the previous topic, the one you quoted me, its been a while since we had any problems with backup / restore functionality.
The last one was back in early SEPTEMBER, and it was fixed in the other week. Backup / Restore is truly stable right now.

Here is a topic which with some reminds that will save you a lot of trouble in case anything went wrong with your re-instalation or upgrade.

That being said I don’t see the point to create a fuzz, with big red letters, prints and statements that says “we don’t solve bugs” or “sc is useless”.
What’s the point with the caps lock anyway?

It just isn’t truth.

And as always, thank you for the feedback.

1 Like

How can you say it is BACKUP / RESTORE is stable if I cannot restore my files ?
So you asking me to send 60Mb file to your support team every time I need to restore ? I have no paid support (because I’m not going to pay to be able to report bugs).
I have asked your support last time what did they do to the backup file so I was able to restore it (after their fix) but they did not answer that question :frowning:
It took a week to get single file to NetMake because they kept asking me to send 35Mb backup through email (which obviously cannot go through). So how can I get my projects restored ?


Send it to us.
There are a lot of ways to give us the file, e-mail, dropbox, FTP, download link…

Although backup / restore routine was remade, the previous one are still inside the Scriptcase.
Because there are people with old backups and old SC versions. (I’ve explained this to you in another topic)…

If you follow the tips inside the topic I’ve linked below you probably won’t have any issue with backup & restore ever, with or without bugs.

Now I might be wrong, but it seems to me that you’re just curious about what the support did to your backup.

There are some security in the backups so people can’t glitch it (like keep exporting / importing projects using trial versions to work, build and publish stuffs for example).
You said you had a licence problem, so this might be the issue. It doesn’t make it a bug.

However I can’t tell for sure, but if you really think it’s a bug stop concealing information and give us details to help us help you (and others).

1 Like

The Import issue was reported 2 years ago or so. My license issue came up in December/2016 when I had to renew it. I offered download link to NM but they said they will not going to use it. Email would not work - files are to big. I will think about dropbox to see if I can use it. The tips about the installation might be helpful for some but I have already managed my installation issues and seems the SC works fine, although I still cannot RESTORE older projects (made with SC8). This problem always happens to me when I need to upgrade, reinstall etc. Otherwise it works fine, so there is something that is happening during Installation or Upgrade that makes those files incompatible. I undesrtand your security concerns but handing all users backups while only single user can have numerous files in sizes of 30-100Mb sounds rather insane. I hope you are right about the fact that only older projects have the issues. I was able restore project from November/2016 without issues but the ones from Spring/2016 will not work. I will try to put my backup files on my FTP sever and PM you with the credentials so you can download it and fix it.

Thanks - Arthur

Backup and Restore had serious issues some time ago, and has I told you the routine was remade and is stable now.
Thank you for understanding Arthur, please PM @John_L_Santos with the credentials. He will assign someone from test team to handle it for you.

I strongly recommend you to make new backups to replace your old ones whenever is possible to avoid this.

Remember the topic you found that had people complaining about this last year?
We, by mistake, released an update with a bugged BKP/RTR routine and if you tried to restore some backup with this bugged release it would block your backup files.
Unfortunately we can’t “fix” this problem if the backup is blocked, we have to check it manually for security reasons.

OK Cavadinha, I PM’ed John S. , waiting for response

Hi. I need urgent help. I Lost my DEV server.

  1. I reinstalold. ( Last backup say, “The file was not created by Scriptcase Version 9”
    The file is : Complex_Management_PRD_20220724052352

I see that a consutant say “Do the backup again…” I cannot, I lost my system. this is kind of urgent


Well, the question is, in which version did you make your backup? There are several ways to export or create a backup, you need to be sure that you use the correct restore. If you have made a backup in an older version, you must reinstall this one and start from there.

Hi all,

I confirm this problem even when backups are made with same version. Analising that, it seems to be the maxfiles in PHP.INI from SC is small and that is the main reason. If the versions are the same (backup and restore, you can put your backup in the SC folder which receives the zip generated by SC’s backup, located in /wwwroot/scriptcase/backup, uncompress it and it will appear in the RESTORE option from SC and you can restore your backup normally.