Confirmation needed: Why no database list on connection editor in SC8.1 projects?

We are unable to deploy projects developed with SC 8.1 - this is the first project we are attempting to deploy in a while, largely because we have never had much luck with Scriptcase’s project deployment approach.

In this case we get to the point where the connection can be configured and tests OK. We have tried a variety of localhost and remote host mysql servers and in all cases can connect OK.

However, in all cases the database list at the bottom of the connection editor form is empty.

I see from posts elsewhere where others are suffering the same frustrations, various version issues of PHP are blamed.

We have tried a number of server environments (Linux, Apache) with PHP versions 5.3.n through to 5.6.n - all suffer from the same problem.

Is there anything to be done or should I just move on?

Wich RDBMS? Did you pressed List Databases button?

MySQLi 5.5 - and yes, pressed and clicked like a madman.

The issue is PHP - we installed the latest PHP 5.6 and were able to connect.

It seems crazy that the development cycle occurs in PHP 5.4, yet PHP 5.6 is needed as the deployed “production” environment.

I’ve said it before, I’ll say it again; Scriptcase’s weakest link is it’s deployment strategy. One can spend more time sorting out the deployment environment then developing the project.

Deploy on 5.4 Works as expected. Didnt tried php5.5 and never has problem deploying, using shared hostng and private servers (Windows Linux)

Thanks for the feedback, but my previous comments stand. We still have one remaining issue on one server where a grid application presents a white screen.

Note to the SC team; the reason we are not renewing our subscription is because of the constant deployment issues. Not once have I seen one go smoothly, but perhaps after 40 years in the computing industries I have simply become too old, senile and stupid.

I am pretty amazed. I suggest you grab UniserverZ or wamp and test on those if you have difficulty with your deployments. Often it is an issue of bad configuration in the apache configs or in the php ini file.
Some things dont work just because of having a popup blocker that blocks your deployment domain…

I think you miss the point of my criticism; I have clients world wide. SO when I send them software to install I usually cannot be there. The people are usually, as in the case at hand, qualified & competent ITC workers. It reflects badly on the developer when software deployment installers forwarded to remote customers do not install intuitively or as described.

Anyway, it doesn’t matter now. The deployment gave us nothing but grief, like name application folder name conflicts when using “Friendly URLs” (see my post…ames-confusion). We gave up in the end and re-wrote the application with something else.

This will probably be my last post here, and some of you may say good riddance. But I can only re-iterate that I have used SC since version 5.2 and the deployment of projects has always been a PITA for me. Of course, it may be that SC is not suited for me, or the sort work I do, or the clients I have.

I wish you all well and the best in your endeavours.