CSS disappearing on deployment for only grids with nested grids

I saw a similar post in bugs from last year and didn’t see a resolve on it. I commented on it to see if it had been fixed or how it was fixed, but there was no answer. So I figured I would make a new post.
The issue is this:
CSS Themes work fine in the scriptcase development area for all applications.
After deployment to my server, (WAMPSERVER 2.5, Windows 10 Pro, Scriptcase 8.1) any grid application that has a nested grid application attached to it, loses it’s CSS Theme formatting. Doesn’t matter which theme is chosen. All other applications work fine. This happens across all platforms (IE, Chrome, Firefox, Android, etc).
Anyone else having this issue, or does anyone have any ideas why it looks fine in the scripcase development area and not when deployed for just this specific type of application only?
Oh, and if I remove the nested grid and deploy, the CSS works fine.
Thanks!

hmm…no one else has this problem? seems like this bug has been reported so long ago!

I’ve updated prod environment, made sure to have the latest updates to scriptcase, etc. It’s unfortunately still happening. And, I found that this is only happening to the scriptcase 8.1 applications. My scriptcase 7 apps all work just fine when there is a nested grid.

Update: Issue resolved. It took quite a few attempts but eventually this is what it took to remedy the issue. I had downloaded the latest common files and installed them when this originally happened but I decided to do it again today. It didn’t work. So I went into the netmake folder under program files and into the scriptcase app folder. I manually copied the lib and application folder for my program onto my server. This gave me the error that scriptcase prod couldn’t be found, which was expected. At that point I re-deployed the application. For whatever reason, it worked this time. I’m happy lol :slight_smile:

Hi, I have exaclty the same problem in V9. The copy trick did not help. My box is Linux. Can anyone help?

I had the same Problem. I have ubuntu 16.04 with Scriptcase v9. I resolved this issue changing permissions, I executed “chmod 755 * -R” in my project folder and then execute “chmod 777 /tmp -R” allowing to write in the tmp folder.

That’s correct.

For Nested grid to work - we need to get chmod 777 * for all the subdirectories. Not sure which specific directory is looking for 777 access.

If not then the CSS is not getting applied and only main grid data appears.

I tried just tmp - but no luck