Deploy is completely broken for linux installs, including AWS

There is almost nothing that works when deploying applications developed on linux and deploying to AWS:

  1. Select .tar.gz archive, and a file with .tar.gz is created, but it is in tar format, not tar.gz. (The tar command line used by SC is probably missing the ‘z’ argument.)

  2. Deploy an application to a server, point a browser at that application, you’re presented with the prod/lib/php login to set up connections. This is the only URL the site will ever present to a user unless the initial application is specified on the URL. I reported this a year ago.

  3. While setting up multiple connections for an application, only the first can be edited. The others disappear from the list as soon as the first one is created.

  4. The file permissions are wrong - horribly wrong. They’ve been wrong FOR YEARS.

  5. Applications test just fine but are missing custom graphics when deployed. This may have been fixed recently, but the inability to deploy anything makes that irrelevant.

  6. 175 MiB for sc_prod???

Has this been fixed?

As far as I can tell, no.

Last time I tried, back in February, no.

Deploying on Linux is painful, the vendor doesn’t have the in-house talent to correct the problems, and they don’t appear to be interested in spending the money to contract someone with the talent to do it for them.

Caveat: painful, but do-able.

The connections are a problem: after setting up the connections, the index should be overwritten with your web. That doesn’t happen, but the connections are saved. You’ll have to move your correct link to the index for your server config.

Permissions are wide open (+arwx) or octal 0777. Anyone can read/write anywhere within your deployed file structure. I’ve posted a way to correct this for older versions elsewhere on this forum, but those instructions might cause trouble on versions since then.

The OP #5 issue was corrected around the time 9.3 arrived. No one was more surprised than me.

It’s a useful product, but the vendor’s workforce are Windows people, so security is never considered and things tend to be bloaty, janky and gigantic.

1 Like