I have Javascript files for my application and I don’t know how to store them. When I publish my application, files are not sent.
I tried in my directory app/_lib/js, but that doesn’t work.

Merci !

Appearantly your javascript files are not part of the scriptcase project. Best way now is to create a valid instance on your local development engine. You can put the javascript on the location you need an deploy using your local root. Then with filezilla or any other ftp tool you upload the necessary directories from development including the javascript files to production.

Thanks for the answer.
I think that it is the similar for the images ?

Merci !

It is similar for all things not known to SC. So if you have images on directories used which are not imported into the SC environment then you need to take care of them yourself.

I am fairly new at using scriptcase and have not tried to deploying my project. I have made a module for a customer and they want to test it. So I need to create a new directory and another copy of the mysql database. So that my test will be different from my development directory and database in the same web host. Is there any documentation that I can use to guide me with what i want to do. MY server is CentOS and back end is MySQL.

I would appreciate help so I can have a test site for our client to test.

Best regards,


deploy scriptcase local on your development engine i.e. in a wamp environement. Put your javascriptfiles on the spot you need them. Test your ‘semi’ production environement. Then deploy from here with any ftp client, i.e. FileZilla.

Dear Sir … I have deployed a project and have successfully uploaded the files to the new directory and i have created a clone of the database I used for development. I have also configured the connection and i got successful test on the connection to my clone database. I have also changed the directory permissions because we are using a Unix box. But when I run the login its issuing an error as shown on the attachments.

I have tried editing the connection, always returns successful test. So I dont know what is wrong with my deployment/

Please give me information on how to resolve this issue.

Best regards,


sucess in making a connection.JPG

error in login.JPG

detail  on the error.JPG

Looks like your connection is still pointing to the localhost
Did you configure the production environment ?

If you enter into your address bar
The prod configuration should come up