Deployment in Ubuntu AWS environment - Common libs not found


After deploying in AWS Ubuntu environment, I have got all the application files and also I can see the the “_lib” folder with “prod” subdirectory with files.

But when I try to reach the application - I am getting an error

Common libs not found: /opt/bitnami/application_subfolder/_lib/prod

The application is hosted on http://domainname/AASPAreports and not in the main domain name.

Once I try to reach the application in the browser, the URL is changed to http://domainname/AASPAreports/Initial_Application_Name - This is good.

But I get an error message saying

Common libs not found: /opt/bitnami/application_subfolder/_lib/prod

If I try to access http://domainname/AASPAreports/_lib then I am redirected to the Production environment setup login page where the system asks for the password to setup the connections.

I tried to setup the connection details through this page. But once I am done with this and back to the main application page http://domainname/AASPAreports/ then I get the same old error - Common libs not found.

Can you please help me in getting this deployment working.


Looks like scriptcase doesn’t like to get it published on subfolder.

We got another application running in the main domain name - that’s why we planned for subfolder http://domainname/scriptcaseapplication - but not worked through.

So, I changed to http://domainname:8080 and it started working.