Error for login on deployed project: Sorry, but user is not active!

I have just deployed an application to an Ubuntu server and when I try to log in with a user that is already in the database (i.e. SC’s own security user table), I get the error “Sorry but user is not active”). Now when I run the application on my Windows 7 development machine with security enabled, I can log in as the same user without any problems (the database was exported from the development machine and imported to the Ubuntu test server).

I have used SC’s own group/application enabled security.

Does this ring a bell for anyone?

I assume you have checked your tables that they match your development? I had this once, but in my case the security tables where not setup right.

Yes, I checked that.

I finally got it solved by clearing all users in the development database as well as update the code in the validation event of the login app, which seemed to be from an older SC version (even if generated with SC 8.1). After redeployment of both the regenerated security applications as well as the contents of the security tables, I got it to work.

In general, the security applications could do with a refresher from SC.

Hello Aducom:

Good to see you again!. To me i use the elearning system sample from Scriptcase and have the new version of 9.10. The Error for login is because the database is not in the elearning system? or I need to clear the user and make it again. Here is Educational Computer Center e-Learning System

Also I don’t find the database in SC to connect it. I was looking for video but don’t see anything about deployment completely just simple video about it.

Thanks :relaxed:

Jose Luis

Hi Jlocana,
I really cannot remember this, as it has been a while. But one of the main causes can be that Scriptcase never rework their samples when new versions come out. So it is very likely that you import the project that was built by an earlier version causing issues.

1 Like