Error with Quick Search and Sorting on Columns

HI, i generated all my apps with the new version of SC 8. But the Quick search and sorting on Columns are not working. It Only Show a Message Processing all time.
This error is for all my apps with quick search and reports with sorting on Columns.
I tested with Chrome and Firefox and got same error.
Any idea how solve it?

When i work in Development and i try to use the quick search or Sorting columns i get same error:

Fatal error: Class ‘Services_JSON’ not found in C:\Program Files\NetMake\v71\wwwroot\sc8\app\PosMS\rpt_grid_pro_listagral\index.php on line 1758

That appears to be one of your own programs, since I donot recognise PosMS. I see this piece: rpt_grid_p ro_listagral are you sure it shouldnt be rpt_grid_p\ro_listagral ??
Which means that somewhere there is a \ missing…

I have a folder named PosMS, my apps is in this folder. ALL my Apps have same problem. I use this app for this test for evaluating (rpt_grid_pro_listagral) with other have same error. I can see SC insert a space to my app name to rpt_grid_p\ro_listagral. I do know why SC do that.
The error generated is because SC not found this class ‘Services_JSON’. This class must be of SC.

My apps was working fine. never i had this problem.
This error is in general for ALL my apps with Quick search and Sorting on Columns.

The line 1758 cause this error is:

$oJson = new Services_JSON();

Any idea how Fix it?

Well in the generated code you should see stuff similar to this:
if (!class_exists(‘Services_JSON’))
include_once(dirname(FILE) . ‘/form_SCRIPTCASE_STUURGEGEVENS_json.php’);
Hence my conclusion is that file even there? And if so can it be reached (as in are the rights ok?)? Check your main index.php from your application…

Thanks you rr for your help.

My apps was generated with olds version to SC8.000047 Maybe 8.000045, i geneted the source code newly to All my Apps and it Worked.
I Think that every time SC release a new version is good idea generate source code for all apps.

Thanks you.

That is absolutely something to do…

Same problem, same solution. Had the same problem in development, just regenerated all and done.