[FEATURE] Deleted applications still being picked up by Security->Synchronize Applications

Like most projects I have deleted some unwanted applications. After deletion, the applications do not now show up in any of the folders which is what I would expect. They do not show up in the selectable applications to deploy and they do not show up in the selectable Initial Application when deploying. However, if I run Synchronize Applications in the Security Menu then they are found and included.

This results in entries for these “deleted” applications being stored in the sec_apps and sec_groups_apps tables which means administrators could actual set access rights to them - not good.

I checked all of the folders including: All Application, My Applications, Recents and root and there is no sign of the deleted applications anywhere. But clearly there is a trace somewhere.

This is annoying and is, in my view a bug, as clearly these are deleted applications and are, therefore, no longer wanted.

In the short term is there any way of flushing the deleted applications out of the system?

That is because the synchronize is populated from the generated applications. To solve this issue, delete your generated applications and regenerate. Then you can synchronize to get a clean declaration (first delete the table).

I will try this. If I understand you correctly, even though I have deleted an application, the generated code still exists and that is where the synchronise is picking it up from.

Update: It may be a daft question but where are the generated applications stored so I can delete them? I assume that these are the generated applications within the RAD environment as I know where the generated apps for deployment are stored.


The generated apps are within the /apps/YOURPROJECT folders


I have the same problem…I delete my app, regenerate all apps and nothing…still appear old deleted or renamed apps in sync apps…(I deleted apps table too and nothing)


You have to delete all your generated application in your RAD (app/YOURPROJETFOLDER/ ) regenerate all and delete your developed directory too and publish again (config your app again)…access and delete apps in your app and syncro again…

This is a problem…WDYT???

You have to delete just the not using app, but obviously is faster to delete all folders and regen complete project.

…too and publish again (config your app again)…

Not needed. On production, delete all folders but “_lib” folder and index.php, and deploy again without common libraries and or production env. You save 150MB and configuration is not needed.

Reasons why this happen

SC create a folder for every application generated. It don’t deletes until you order SC to regenerate thiis app. But, If you delete this app on SC, then SC will not delete it because you can’t regen. It’s not a bug, but I maintain this thread because a “Clean” option under “Tools” , to clean the folder, is interesting.


is this problem solved somehow? I tried everything to get rid of some applications, but it doesnt work this way. It works only if I reconfigure the whole security module and that is really bad.


I found out why this is happening. Scriptcase creates a friendly-url for each application (even if you don’t). These files are stored in /public_html/your_url/_lib/friendly_url. Even if you delete the app from your project, ScriptCase will not delete the friendly-url from this folder. The Sync application will also pull from this freindly-url folder to identify apps that require syncing.

I recently had the same issue with my production environment. I only have 70 apps, and each time I sync’d my apps it would find 200 plus applications. I manually deleted all the old friendly-url’s and the issue is resolved even if I sync 20 times in a row.

You may also need to update the database table after removing the obsolete links.


Will D.

Mdove is right

C:\Program Files\NetMake\v9-php73\wwwroot\scriptcase\app\YOUR_URL_lib\friendly_url

The most easy way to find is, access to NetMake folder and helped with the serch tool put the name of your APP and go, delete the archive yourappname.txt and delete
after or bofore you also need to update the database deleteting the app record on table SEC_APPS.