Grid / Editable Grid Form applications Show HTML Content off is not interpreting html

Hi. I’m having an HTML display issue with Grid applications and Editable Grid Forms when using the Multiple Lines Text field setting. Maybe it’s an issue, maybe it’s just how the field works. Please let me know either way. Thanks!

I created a form that uses the HTML Editor to store information in a field called {notes}. This works fine.

I created a grid that shows the field {notes} as a multiple lines of text field. I have the Show HTML Content set to off for this field because I would like to see the html interpreted. When generated, the grid does not interpret or display any of the html content for this field, such as bold text, font sizes, colors or highlights. If you set the indicator to on, it displays all of the tags.

When doing the same process in Editable Grid forms, the field works fine if set to HTML Editor. However, setting the field to Multiple Lines Text with show html set to off does not interpret the tags, but still shows some of the tags, such as paragraph tags. Set the indicator to on and it shows all of the tags.

I have tested this in the latest versions of Chrome, IE/Bing, Firefox and have the same result. I’m running Scriptcase 9.9.013 on a Windows 11 platform using WAMP 3.2.3 as my server running Apache 2.4.46, PHP, MySql 7.5.31

Dear @Lisa.C,

After carrying out tests in the most recent version of Scriptcase, we were unable to identify a problem in the “Multiple Lines Text” field. When defining the field in the Form as HTML Editor and adding tags to it, and creating a grid with the same form table with the field type “Text Multiple Lines”, the interpretation of the tags is done normally.

The HTML Editor field comes from an external component, which in this case is tinymce, and its interpretation of HTML tags is independent of the “Show HTML content” flag. The other fields do not work because they are open fields for user editing, therefore, they will always show the tags. The only field it will interpret is the “Label” type field, as it is a read-only field, just as if you use the sc_field_readonly() macro for the “Multiple Line Text” field on the form.

In case you are still facing the problem of non-interpretation of the HTML tags in the field “Text Multiple Lines” in the grid, give us more details about your application so that we can verify. We will be waiting your feedback.

Best Regards!

I switched the form to be multiple lines of text, entered a sample with tags, saved and then ran the grid and it worked fine. Then I switched the field back to being html editor and suddenly the tags worked, for some records, not all. After some more testing I found that if you set the Grid field to only show a specific number of characters this is where the system says no. When I set to 50, none of the tags interpret. Set to 100, some interpret. Set to no value and all interpret. Funky. Give it a try and see what you get.

1 Like