grids with nested grid: "broken" CSS only when deployed

I have a couple of grid apps with nested grids that work perfectly in my development env (i.e. when run from SC).

When I deploy those grids in my production env, they still work but they are displayed with some CSS info missing or not applied. I only have this issue with grids with nested grids: all grids without nested grids work perfectly in both the dev and the production environment.

This is one of the grid in my dev env.
Note that the nested grid here is collapsed (see the column ‘Lotti’ to the right, with all rows having only the + icon)
I tried different options to show the nested grids, but without solving this issue.

This is how the same grid looks in my prod env.
Note that my prod server is the same box as the SC dev server. The only difference is that deployed SC apps are served to the browser by the standard apache service and PHP provided by the OS (CentOS) and not the by the ones provided by SC


Could you try an incognito window or another browser?
If possible, we can make a remote access via Team Viewer to speed up a solution to this problem.

I just tried Chrome, FireFox and MS Edge.
All of them with normal and incognito windows.
All browsers\modes have the same issue.
It would be great if we could work via TeamViewer.

EDIT- there’s another difference between the dev and prod enironments that I forgot to mention but I don’t think it is relevant: in dev the apps use (SC Apache) HTTP, while in prod they use (CentOS Apache) HTTPS

I know this is an old post but I’m having the exact same issue. Everything works great in scriptcase production environment when running an application that is a grid with a nested grid, but when deployed I lose the css formatting. CSS is fine for all other types of applications but just bombs when it’s a grid with a nested grid. Happens on all browsers\modes\formats. Even happens on my cellphone. I’m running Scriptcase 8.1, WAMPSERVER 2.5, Windows 10 Pro if that helps. Were you able to get this resolved?

I am having the same problem! Can someone from netmake please reply this post?

Ok, to those with the same problem, I managed to solve the problem by updating to the latest common libraries.

Thanks alexckp, I did update the common libraries a few times, but I’m going to try again today to see if there was any change made. Did you have to update anything on your server aside from the common files? Thanks.

**Update, nope, I downloaded and installed the common files again today (12/7/2016) but no luck :frowning:

**Update, 3rd times the charm today. Not sure why, but it finally took! Yeah!! I manually copied the lib and application file folder from the scriptcase folder to my server. Then I re-deployed it again. It took. :smiley:

I just had this issue again with SC9, after deploying a whole project in production to an empty new directory (to clean up all old deployments for the same project on the sames server).
It turned out to be an issue with limited permissions on the “_lib/tmp” sub dir.


Yes for Nested grid to work - we need to get chmod 777 * for all the subdirectories. Not sure which specific directory is looking for 777 access.

If not then the CSS is not getting applied and only main grid data appears.