Installing Scriptcase on Mac OSX Plataform


In our Knowledgement base we release a new tutorial to how install Scriptcase in Mac OS environment.

You can check in this link below:

Re: Installing Scriptcase on Mac OSX Plataform

In the tutorial you mentioned that we need the extension Zen Guard Loader right?
But that extension is 700 usd. there is an option to use scriptcase without that extension?

Thank you.

Re: Installing Scriptcase on Mac OSX Plataform

Oh no no! sorry sorry sorry! I make a mistake when i did the download.
My scriptcase is running right now!
Sorry! my bad.

Re: Installing Scriptcase on Mac OSX Plataform

I am trying to install on a new MAC but have problems and need help:

I Followed the tutorial and got stack after starting the server see below:

MacBook-Pro:local USER??? $ sudo /usr/local/zend/bin/ start
Password: ----------------------->>>>> password is ??? my pc pw

Starting Zend Server 5.1.0 …

(48)Address already in use: make_sock: could not bind to address [::]:10088
(48)Address already in use: make_sock: could not bind to address
no listening sockets available, shutting down
Unable to open logs
/usr/local/zend/bin/apachectl start [FAILED] <<<<<<<< ===== problem
spawn-fcgi: socket is already in use, can’t spawn <<<<<<<< ===== problem
lighttpd watchdog is up and running… [OK]
[ 16.04.2011 08:48:02 SYSTEM] watchdog for lighttpd is running.
[ 16.04.2011 08:48:02 SYSTEM] lighttpd is running.
Starting MySQL
java_daemon watchdog is up and running… [OK]
[ 16.04.2011 08:48:02 SYSTEM] watchdog for java_daemon is running.
[ 16.04.2011 08:48:02 SYSTEM] java_daemon is running.

Zend Server started…
MacBook-Pro:local USER 1$


NEXT STEP: Go to Applications and click on ZEND application to start ZEND GUARD
Enter the password


Failed to access Web server: Unable to read response, or response is empty

Please Help !!!

Re: Installing Scriptcase on Mac OSX Plataform (Resolved)

Sorry my problem with ZEND server install seems resolved.
What I did:
I had to open the terminal and run this command:

sudo /usr/local/zend/bin/ start

apache showed up [OK] no problems detected I am able to get into zend and started ZEND GUARD.

Gone to finish installing SC now.


Re: Installing Scriptcase on Mac OSX Plataform(STUCK )

Zend is installed but now I cannot install ScriptCase.

First step says to go this url to start installing ScriptCase on the mac OS.

I clicked on the link : http://localhost:10088/scriptcase5/

I get a blank page and the url changes
from this: http://localhost:10088/scriptcase5/
to this: http://localhost:10088/scriptcase5/index.php

But does not give me the next screen as in the tutorial, I get a blank page:

I looked at the tutorial example screen below and noticed the url on the instructions with the login page has this: http://localhost:10088/scriptcase5/devel/iface/login.php

Went to my system and I did find the directory devel/iface and the script login.php is there but when I type it on the URL still get a blank page with no errors.

I need help this time…

Re: Installing Scriptcase on Mac OSX Plataform

The mac problem is back. Now that I gained some experience with Scriptcase on Mac, I can provide more info. On my Mac with Snow Leopard I succeed to install SC (a real pain!!). Now we have a new Mac with 10.7.4 (Lion). Install process as discribed in the installation instruction. To our surprise I worked ad hoc ! The happines laste only until we compiled the first application: Error message: date() is not save to run… Ok, what ever it means we cannot recompile SC. Second message from the Zend : extrem slow request ?? Finally we found this message in the zend server: Incompatible file format: The encoded file has format major ID 65540, whereas the Loader expects 2.
Severity : Critical
Result: Scriptcase does not start.
Tried to uninstall the sw, no effect, by the way to get rid of Zend is almost impossible.
Conclusion: Since several years I try to run Scriptcase on Mac, it is always the same. Due to overengineered security and copy protection it is very difficult to install it on Macs. Use Win instaed.

Re: Installing Scriptcase on Mac OSX Plataform

Hello jgunter,

Are you trying to install SC 5 or 6? Which PHP version is your server running in? Could you send me your diagnosis (help --> diagnosis - or, as you are having problems access it directly on your browser)?

Bernhard Bernsmann

Re: Installing Scriptcase on Mac OSX Plataform

The loader is part of the community edition, it’s no charge.

Re: Installing Scriptcase on Mac OSX Plataform


I want to share my experience and mac user.

For months stop using Windows, would not return for many reasons, I have had many problems getting decently with SC.

After Achieving instlar, errors of folder permissions.
Not updated.
It does not validate the license.
At the end of this creates a new license and said that he had no permission to my server.

Please ask a professional installer for Mac that allows us to download the updates and validate the license, it is difficult and exhausting.
Thanks for your understanding.

Re: Installing Scriptcase on Mac OSX Plataform

Since todays update it is possible (after the first installation) to update online.
The licenciation process also works online with Mac OS Mountain Lion (maybe also with previous versions) by now.

[SIZE=12px]Hi you all, [/SIZE]
[SIZE=12px]Apologize for my English …[/SIZE]
[SIZE=12px] [/SIZE]
[SIZE=12px]Here is what I have done to install Scriptcase on Mac OSx under Mamp Pro (assuming it will run under Mamp free version)[/SIZE]
[SIZE=12px] [/SIZE]
[SIZE=12px]Remark : Mamp Pro is one of the solutions to run LAMP installation on MacOSx. It could seem really redundant with the default and preexisting apache server running on MacOSx … I assume to be a lazy user. ;-)[/SIZE]
[SIZE=12px] [/SIZE]
[SIZE=12px]Starting with this configuration : [/SIZE]

  • OSx El capitan 10.11.5
  • Mamp Pro 3.5 including [LIST]
  • PHP 5.6.10
  • MySQL 5.5.42
  • Apache 2
[/LIST] [SIZE=12px]Once Mamp Pro is installed you just need to add Zend Guard Loader / Zend Optimizer . You'll have to register at Zend and download via this link[/SIZE] [SIZE=12px] [/SIZE] [SIZE=12px]Untar the archive, you get :[/SIZE]
  • (not needed already installed with Mamp Pro)
  • (What we need !)
[SIZE=12px] [/SIZE] [SIZE=12px]​You have to [/SIZE] [LIST=1]
  • Copy in the extensions folder of your php version. Depending of your PHP version, you could find it i.e. for PHP 5.6.10 the path is /Applications/MAMP/bin/php/php5.6.10/lib/php/extensions/no-debug-non-zts-20131226. You could try a Finder search for "" it's in the same folder (for the right php version)
  • Update your php.ini version. two ways : [LIST=1]
  • Map Pro : using the menu Files/ Templates/Php/versionxxx
  • the path for php 5.6.10 is /Applications/MAMP/conf/php5.6.10/php.ini [/LIST]
  • enter this new section in php.ini ```
    zend_extension = "/Applications/MAMP/bin/php/php5.6.10/lib/php/extensions/no-debug-non-zts-20131226/"
    ; Enables loading encoded scripts. The default value is On
    ; Disable license checks (for performance reasons)
    <li>Reboot your server using Mamp Pro
    <li>Enjoy installing Scriptcase
    [/LIST]  [SIZE=12px]This is a standard sketch installation using Mamp pro. It works for me but will depend on each configuration and possibly vary a little ... The core process will remain the same.[/SIZE]
  • Hi,
    I am having a similar problem. Sometimes apache starts with no issue and sometimes it does not start. The link above is not working. can somebody help?