Issue with MySQL connection using SSL

Hi,

I have an issue with a MySQL (MariaDB) connection between 2 servers over SSL. One server is running Scriptcase and the other one the MySQL database.

I have configured MySQL using SSL according to this manual: https://www.digitalocean.com/community/tutorials/how-to-configure-ssl-tls-for-mysql-on-ubuntu-16-04

Certificate information is configured in 50-mysql-clients.cnf:
[client]
ssl-ca=/etc/mysql/ssl/ca-cert.pem
ssl-cert=/etc/mysql/ssl/client-cert.pem
ssl-key=/etc/mysql/ssl/client-key.pem

With the MySQL client I can connect to the MySQL server manually. I can use databases, run sql etc.

When I create a new connection to the same database it seems to work fine in SC developer. When I test the connection in the configuration form of the connection I get “Connection success” and I can get a list of database.
The fields in the security tab are empty, except for the “Use SSL” checkbox (because it uses the information from the MySQL client info in config file mentioned above.

When I run an application using this connection I get an error ""Access denied for user ‘<username>’@’<servername>’ (using password: YES).

In the /var/log/mysql/error.log I see the following:
When I press “Test connection” I don’t get an error, but when I open the “Edit connection” screen or when I list the databases I get the same error as above in my error.log, but it doesn’t appear in Scriptcase itself (what means to me, that error handling in Scriptcase DB configuration is not OK).

When I fill in the certificate fields in the DB configuration security tab, I have the same issue.

Anybody facing the same issue? What is causing this issue?

Configuration:

  • Apache 2.4.41
  • MariaDB 10.4.12
  • Ubuntu 18.04
  • PHP 7.3.15

Regards,
Martin